Can I stop messages from opening automatically?

Discussion in 'OS X Mountain Lion (10.8)' started by Gonky, Oct 18, 2012.

  1. Gonky
    Expand Collapse
    macrumors regular

    Gonky

    Joined:
    Oct 8, 2010
    Location:
    UK
    #1
    Every time I get a new iMessage the app opens onto my desktop, which is really frustrating. I do use the app quite regularly but also use the computer to demo things and don't want colleagues to see my girlfriend letting me know that dinner is ready or something. I have 'when I quit messages set my status to offline' ticked in preferences.
     
  2. Weaselboy
    Expand Collapse
    macrumors Core

    Weaselboy

    Joined:
    Jan 23, 2005
    #2
    I notice the same thing even when the app is not running. It must have some sort of system service that monitors for new messages. The only way I see to stop it is to uncheck "enable this account" in the iMessage accounts section of the preference panel.
     
  3. Gonky
    Expand Collapse
    thread starter macrumors regular

    Gonky

    Joined:
    Oct 8, 2010
    Location:
    UK
    #3
    Frustrating because I do use it, just don't want it forced upon me. Never used to do with with the messages beta on Lion!
     
  4. msavwah
    Expand Collapse
    macrumors 6502

    Joined:
    Apr 5, 2010
    Location:
    Oahu
    #4
    command H keeps it down for me.

    when you have it open, select "hide"
     
  5. RoelJuun
    Expand Collapse
    macrumors 6502

    RoelJuun

    Joined:
    Aug 31, 2010
    Location:
    Netherlands
    #5
    Having the same problem, why is there not a simple notification that you click and THEN open Messages…

    Oh and after they fixed that, make the application usable. Half of my messages don't arrive, displaying the red exclamation sign. Really, really annoying. And the application sometimes suddenly deletes earlier messages when updating (and the updates are often NOT pushed but at random moments.)

    Shame on you Apple.
     
  6. The Economist
    Expand Collapse
    macrumors 6502

    The Economist

    Joined:
    Apr 4, 2011
    Location:
    Mexico
    #6
    As far as I know, Messages is not supposed to automatically open when you receive a new message. You receive a visual notification and only if you click on it the application will open.

    Have you tried turning Do Not Disturb on? Open Notification Center and scroll down, you will see a switch. Try that and see what happens.
     
  7. Badagri
    Expand Collapse
    macrumors 6502

    Joined:
    Aug 9, 2012
    Location:
    UK
    #7
    You're 100% correct. It has never opened to me. Can even stop the little pop up balloons from appearing on the desktop and have it only display on the notification area. Or just stop it altogether.
     
  8. fisherking
    Expand Collapse
    macrumors 68040

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    brooklyn
    #8
    same issue here; it just opens on it's own when there's a message.
    so...disabled my account. will use my phone for now.

    this needs a fix asap!..
     
  9. shaun3000
    Expand Collapse
    macrumors newbie

    Joined:
    Dec 2, 2006
    #9
    Solution

    From: https://discussions.apple.com/thread/4422373?tstart=60
     
  10. dopeelf
    Expand Collapse
    macrumors newbie

    Joined:
    Oct 20, 2012
    #10
    For me it was my blackmagic card. It has a start app when camera is connected thing. Unticked it and now it doesn't start.
     

Share This Page