1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Can not disable Internet Sharing

Discussion in 'Mac OS X Lion (10.7)' started by oliversl, May 31, 2012.

  1. macrumors 65816

    #1
    Hi,
    I have run into a bug I think.

    I enabled Internet Sharing for a test, sharing the USB Ethernet using the WiFi.

    The the computer hibernated, after waking up I can no longer disable Internet Sharing. Now, every time the computer wakes up, the Internet Sharing is enabled using the WiFi. Even if there is no USB Ethernet adapter.

    I tryied reboot, conecting the USB Ethernet and enable/disable Internet Sharing and it is solve until the computer sleeps or reboot.

    My only solution is to run:
    sudo ifconfig en0 down
    sudo ifconfig en0 up

    Anyone know how to solve this?

    Many thanks
    Oliver
     
  2. macrumors 65816

    #2
    Sorry about the spam, I solved the problem.

    The problem was that hotspotshield was installed when I was using internet sharing, so I re-installed hotspotshield, re-configured internet sharing and then unconfigured and uninstalled hotspotshield. Also, I closed vmware Fussion this time.

    HTH
    Oliver
     

Share This Page