Cannot Access Time & Date Preferences

Discussion in 'PowerPC Macs' started by rocklingham, Sep 15, 2010.

  1. macrumors newbie

    Joined:
    Sep 15, 2010
    #1
    My Powerbook G4 Titanium is running OSX Tiger and will not open the Date & Time preferences - instead it gives the error message 'System Preferences closed down unexpectedly' with an option to send info to Apple.

    This is an issue because the date has reset to 1970 and when I start the mac the time is always 04:00. I tried leaving it connected to the wi-fi overnight to see if the time servers would do their thing, but no luck.

    I'd appreciate some help in solving this. Thanks.
     
  2. macrumors 603

    iSaint

    Joined:
    May 26, 2004
    Location:
    South Mississippi y'all, near the water!
    #2
    Have you tried to repair permissions in the disk utility?
     
  3. macrumors 6502

    Joined:
    Sep 7, 2010
    #3
    Steps:
    1.) Repair Permissions
    2.) Run cron tasks
    3.) empty your caches
    4.) restart computer and zap pram (check apple for how to do this)
    5.) see if issues persist
    *.)If yes post back and we will evaluate other options.

    Cheers
     
  4. thread starter macrumors newbie

    Joined:
    Sep 15, 2010
    #4
    Thanks for the replies. I have gone through those steps but the problem remains.:(

    Any more ideas?
     
  5. macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #5
  6. thread starter macrumors newbie

    Joined:
    Sep 15, 2010
    #6
    OK. I have replaced the PRAM battery, but I still cannot access the Date & Time in the System Preferences.
    I ran through the steps above, again, and even re-set the PMU. But there's still no change - Time is at 0400 and date is 1 January 1970 when I boot-up.

    Any more ideas on how to fix this?
    --------------
    Powerbook G4 Titanium (Onyx) 550Mhz 256Mb RAM OS X Tiger
    Mac Mini 2.26Ghz Intel Core 2 Duo 2Gb RAM OS X Snow Leopard
    iPhone 3G
     
  7. macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
  8. macrumors 6502a

    raysfan81

    Joined:
    Oct 6, 2009
    Location:
    North Carolina
    #8
    If you have done everything else that may be what you have to do to get it working.
     
  9. macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #9
  10. thread starter macrumors newbie

    Joined:
    Sep 15, 2010
    #10
    I tried a new account but the problem was still there.

    I will have a go at safe-mode later today. If that doesn't work then I'll re-install OS X. I'll let you know how it goes.

    Thanks.
     
  11. thread starter macrumors newbie

    Joined:
    Sep 15, 2010
    #11
    Dewguy1999 - thanks, the safe boot gave me access to the Date & Time preferences which I have changed, restarted the powerbook in normal mode and everything now seems to be back to normal.

    Thank you to everyone for giving me help to resolve this issue - I now know more about my Mac than I did before!
     
  12. macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #12
    Glad to hear that worked for you. :)

    I always tell new computer/mac users "No matter how little you think you know, there's always someone out there who knows less and can use your help." A case-in-point is my father-in-law who started using Macs about 10-years ago when he was in his sixties and has never used a PC, helps his PC using friends based on the knowledge he's gained from using his Mac, but yet he still thinks that he doesn't know anything about computers. :rolleyes:
     

Share This Page