Resolved cannot connect to home wifi with iphone 4 :/

Discussion in 'iPhone Tips, Help and Troubleshooting' started by daniel-shi, Jul 19, 2011.

  1. daniel-shi, Jul 19, 2011
    Last edited: Jul 19, 2011

    macrumors member

    Joined:
    Nov 26, 2010
    #1
    hey guys,

    a while ago i could connect to my home wifi with my iphone 4 and lately almost 2 months ago i cant. Its an iPhone 4 16GB, and I'll upload some images so i can help you guys understand :)

    photo 1.PNG
    ok so photo one (above) shows that I can see my network, and i've blacked it out for security and all that.

    photo 2.PNG
    photo 2 (Above) shows that with my correct password and such in, my phone still rejects to connect, but with photo 3 (below) it shows a tick next to the name, but its actually not connected and you can see i still have 3g up the top.

    photo 3.PNG

    Can you guys help me at all? If so that would be great because all i use now is 3g and it is really annoying and costly to my bill. TYIA

    ps, if you guys need router/modem information and such, just tell me and ill be happy to let you know :)
     
  2. macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
    #2
    A simple fix may be by deleting the 'network' that you phone recognises - 'Forget this network', then set it up again.
     
  3. macrumors member

    Joined:
    May 5, 2011
    #3
    On my wi-fi I have had to tweak the wi-fi settings on my computer to get my iPhone to work. One day it's fine, the next, no conection. I'm at work, so I can't tell you what I changed.
     
  4. macrumors member

    Joined:
    Nov 1, 2010
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_9 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8E501 Safari/6533.18.5)

    Goto Setting-Reset-reset network setting...... Then re-enter your wifi password... Hope that helps
     
  5. thread starter macrumors member

    Joined:
    Nov 26, 2010
    #5
    there is no 'forget this network'. if i tap the blue arrow, it shows nothing (image below)

    photo.PNG
     
  6. thread starter macrumors member

    Joined:
    Nov 26, 2010
    #6
    what do you mean by tweak the wifi settings? could you provide more detail?
     
  7. macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
  8. thread starter macrumors member

    Joined:
    Nov 26, 2010
    #8
    *fixed*

    hey guys, thanks for all your help. i rang the apple guys and they suggested to turn off my security to see if it was a problem with the security code, and it seems it was, so it is all fixed. thanks :D :)
     
  9. macrumors newbie

    Joined:
    Sep 26, 2011
    Location:
    Wisconsin
    #9
    I suddenly have this problem

    I installed a Motorola Gateway SBG6580 on my Charter cable. It set up fine and I had WiFi throughout the house until an hour ago. I also have a Logitech keyboard for use with the TV. That couldn't connect with the TV internet yesterday, and today my iPhone can't connect to the WiFi. My computer is fully connected with my Airport Express, though.

    Where is the problem? The lights are all green on the front of the modem, and the Motorola network shows up on the iPhone as normal, but I get the "unable to connect" message.

    Where is security in Settings? Why doesn't it ask for a password?
     

Share This Page