Cannot Copy Songs from Itune to iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by kevhui, Apr 13, 2009.

  1. macrumors regular

    Joined:
    Apr 24, 2008
    #1
    Hi,

    I recently "relocated" my iTune Music Folder to a NAS by the following steps:

    1. Copy the existing iTune Music Folder to NAS.
    2. Selected all the songs in iTune Library and deleted them
    3. in the Preference->Advanced, changed the iTune Music Folder to the NAS location.
    4. In File -> Add to Library, selected the NAS folder

    The relocationed seemed working because when I selected a song and Get Info, the location shown is the NAS.

    However, I can no longer drag and copy songs from the iTune library to my iPhone - that is no plus sign when I drag over to iPhone.

    Your help is very much appreciated.
     
  2. macrumors newbie

    Joined:
    Aug 28, 2008
    #2
    You didn't mention whether this was on Windows or Mac, but if the former I have discovered that I will have this issue unless I assign the NAS a drive letter.

    Have you done that already or are you just connecting via a standard network path?
     
  3. macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #3
  4. thread starter macrumors regular

    Joined:
    Apr 24, 2008
    #4
    It is a Mac.

    I was thinking to "create a new library" by means of Library->Consolidate, which would force Itune to start all over again.

    I will try this tonight.
     

Share This Page