Cannot open new or old files in Garageband 11 although Magic Garageband works.

Discussion in 'Mac Applications and Mac App Store' started by themusicmanrk, Jan 6, 2013.

  1. macrumors newbie

    Joined:
    Jan 6, 2013
    #1
    I get an error message saying: The File Couldn't Be Opened either when clicking on the New Project button, an old file or in Magic Garageband the Open in Garageband button. I already tried one suggestion on the web about deleting the plist and letting Garageband recreate it, but that didn't work. I didn't see this topic in the threads so hope it's not already covered elsewhere. Have not been using Garageband since I upgraded to iLife 11 so didn't realize there was a problem till now. Just got a USB mic and this is the only program I have to use it with. The audio project I wish to work on will have to wait till I can get this solved. Thank you in advance for everyone's help.
     
  2. macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    To save some time troubleshooting, I would suggest testing GarageBand in another user account. If you encounter the same behavior, you may want to consider removing GarageBand and its support files and then reinstalling. You may not have much of any support files to speak of, if you upgraded using the Mac App Store, but be sure to take a look in /Library/Application Support as well as /Library/Receipts.
     
  3. thread starter macrumors newbie

    Joined:
    Jan 6, 2013
    #3
    I have tried your suggestions JediMeister and still a problem.

    Garageband did open completely in a secondary admin. account of mine, but still couldn't get it to open in my main acccount which has other files I need to access to use it. I tried reinstalling it from my original iLife disc, after deleting all files I could find associated with Garageband according to your suggestions and after upgrading via software update, it would still only load Magic Garageband, but gave a file not found error still when loading the main Garageband. My other iLife apps work fine by the way, so it's isolated to this one part of iLife 11.
     
  4. macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    Reinstalling the application was unnecessary, since GarageBand worked fine in another user account. This tells us there is a user-specific file preventing GarageBand from behaving as expected. I would suggest removing files from the following paths: ~/Library/Caches, ~/Library/QuickTime, and also any plists in ~/Library/Preferences relating to GrageBand. After making the sweep, restart the computer fully and try opening GarageBand.
     
  5. thread starter macrumors newbie

    Joined:
    Jan 6, 2013
    #5
    Still will not load main Garageband program.

    I deleted the Garageband cache, the plist (again) and moved the 2 Quicktime extensions to a temporary folder in case they were causing a conflict (perian and an AC3 add-on) and after cold-booting, I had the same results (only Magic Garageband) as before. Thank you for all your assistance so far by the way in this matter.
     
  6. macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    Found this while researching the issue. Give the steps in post 5 by richb330 a try? I'm referring to correcting the permissions on the home folder.

    Here are the detailed instructions if you require: Navigate to Macintosh HD/Users, select your home folder, press :apple:+I or go to File->Get Info. Under the Sharing and Permissions section, open the lock in the bottom right and authenticate using the admin password. Next to your user shortname select Read & Write, then click the gear icon and choose to "Apply to enclosed items". Wait for the process to complete before trying to relaunch GarageBand.
     
  7. thread starter macrumors newbie

    Joined:
    Jan 6, 2013
    #7
    The referral you gave to the other posting solved the problem!

    Thank you so much for your suggestions on this problem and finding the solution to it.
     
  8. macrumors 68040

    Joined:
    Oct 9, 2008
    #8
    Glad we could get that sorted! Happy to help.
     

Share This Page