Can't change time or date

Discussion in 'iOS 7' started by DarkAnnie, Sep 20, 2013.

  1. macrumors member


    Sep 5, 2006
    Just got iOS 7 on both my iPad and iPhone 4S, things seem to run okay, EXCEPT the time is all screwed up on both devices, it's now 12.10 am, but both my devices claim the time to be 5.10 pm. In the time and date settings I can not change this, and the time zone thingy just sets there and keeps on loading and loading. Anyone else?
    Date is correct, just not the time.
  2. macrumors 6502

    Nov 30, 2006
    Apples servers are real busy this week, try setting the time later tonight,

    My ipad did that the other day and i restarted my ipad and the time corrected itself in about 10 minutes.

    Just make sure it is set to automatic.

    Settings-->general-->date and time-->set automatically

  3. macrumors newbie

    Sep 20, 2013
    My time zone will not let me change it

    I also updated to 7.0. Now I am stuck on pst, and I want CST. I did everything everyone suggested. I did a reboot. I set it to auto set, and still nothing. The little wheel continues to turn next to time zone as though it is in progress, but nothing changes. Help please!
  4. thread starter macrumors member


    Sep 5, 2006
    My iphone corrected itself, my iPad is still way off, even after a reboot.
    Wheel just keeps on turning and turning. Annoying.
  5. thread starter macrumors member


    Sep 5, 2006
    This is getting ridiculous! It annoys me to no end that the time is not right on my iPad. Updated the kids iPad yesterday, and I regret it, my 4-year old is so frustrated because he no longer recognizes things the way he used to, and the time is not right on his iPad either.

    So is there a fix for this coming up, or do I have to live with the time being off by 9 hours forever?? :confused:
  6. thread starter macrumors member


    Sep 5, 2006
    I'm losing it! All I can think about is "wrongtimewrongtimewrongtimewrongtimewrongtime"!!!! There's gotta be a fix for this????!!!!???!!
  7. macrumors 603


    Apr 30, 2013
    Los Angeles
    Settings > General > Date/Time > turn off "Set automatically" otherwise it will keep setting the time and date according to your region/time zone.
  8. macrumors 6502a


    Oct 25, 2010
    If you've got Settings/General/Date& Time set to 'Set Automatically' either turn that off and set everything manually as per Armens solution

    or if you want to leave it being set automatically then go to

    Settings / Privacy/ Location Services/

    scroll right down the bottom of that screen to 'System Services' go in there and make sure that 'setting time zone' is enabled
  9. thread starter macrumors member


    Sep 5, 2006
    Desperate, I turned the iPad on and off for the mptieth time, and like magic FINALLY the time corrected itself. Turning off set automatic did nothing for me being able to set the time previously. But now all is well!!! Aaaaaaaaaah!!!

Share This Page