1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Resolved Clamshell mode stopped working help

Discussion in 'MacBook Air' started by heelsbigc, May 19, 2013.

  1. heelsbigc, May 19, 2013
    Last edited: May 22, 2013

    macrumors member

    mid 2011 11"

    I use it connected to a 55" vizio tv in closed clamshell mode probably 75% of the time. It's connected via minidisplayport to vga cable. It's worked perfectly since November of '11 set up this way.

    Tonight I was noodling around and the pointer drifted up to the mirroring icon on the options menu, for some damn reason I tapped and brought up display preferences. In display preferences the resolution was set to "best for this display"? the other option was "scaled". I apparently clicked scaled (part of my problem is I use tap to click and chose scaled by tapping when I was trying to move my pointer).

    The result is clamshell mode is broken, really it seems that the output of the mba to the tv is broken in general.

    It no longer gives me the option to choose "best resolution for this display" If I close the mba I get an "invalid format" message on the tv or sometimes "no signal".

    The only way to output to the tv is to have the display open and mirror it to the tv with the resolution set to 1920x1080 60 htz (but what's displayed on the screen isn't 1920x1080 but the built in lcd's res).

    I vaguely remember having to set the resolution to 1920x1080 at 59 hertz when I first connected to this tv way back when, but that option isn't there to choose now, only 60, 70, 72, 75.

    I've restarted, unplugged everything and replugged, reset pram, This is driving me nucking futs.

  2. macrumors member

    Well, this morning it still won't output to the tv in clamshell mode, but if I set the tv as primary desktop in extended desktop it shows up on the tv with the proper resolution.

    It's still under applecare so I'll call apple and see what they can do.
  3. macrumors 65816

    sorry - i'm at a loss...are you sure it's the computer and not the TV?
    sometimes my HDTV decides there's no HDMI input for no reason and i just have to wait until it recognizes it.
  4. macrumors member

    So i spent the last 3+ hours on the phone with some very helpful apple guys but the problem still persists.

    It seems that when the mba is in clamshell mode, its outputting a resolution that the tv can't handle. If im in mirror it seems to work perfectly, if I'm in extended mode it seems to work perfectly. In clamshell mode the lid is closed so I can't access the display settings to change it back to something the tv can handle.

    Any ideas? Would "screen sharing" with another display while I'm in clamshell mode allow me to change the resolution for the tv?

    Ive got an apple tv that I'm going to try and use airplay mirroring with to see if I can "see" the display preferences while in clamshell.

    It functions perfectly on another older vizio tv in the house. Back in '11, I had some problems getting a mac mini to display properly on this tv, so I returned it for the air which worked fine until last night.

    Right now I'm running it in extended desktop with my tv set as the primary display which seems to function just like clamshell mode but with the mba's built in display open and on. Thats a little distacting but I can live with it. The plus is It functions with the magsafe adapter unpllugged so I can run on battery a little more frequently than I currently do. If I can't get it to function like before are there any negative consequences of operating like this?
  5. macrumors 65816

    again, doesn't the fact that it "works perfectly well" with the other TV suggest that this is a TV-specific issue?

    i confess ignorance on these matters but I would try googling this issue or even checking out a HDTV/VIZIO specific forum.

    it sounds like there's a setting "stuck" on your television set...

    does it work when the screen is open?
    on the other tv you're using the same cable, right?
    it is plugged in and the maglight is coming on?
  6. heelsbigc, May 20, 2013
    Last edited: May 20, 2013

    macrumors member

    Yes, same cable, yes maglight is on, bluetooth keyboard and trackpad all connected and active.

    It works fine with the screen open, but when the screen closes I get the blue transition screen then black, followed a few seconds later by either a "no signal" or "invalid format".

    I was up until 5am sunday morning googling the hell out of it but I can't find anything that matches.

    I was able to use airplay mirroring to see the display preferences with the lid closed, I changed it back to "best for display" from scaled but the problem still persists.

    The fact that it works with the screen open makes me think there has to be some difference in the signal coming from the mba once the lid closes.

    I've posted my problem on the avs forum thread for my tv.
  7. heelsbigc, May 20, 2013
    Last edited: May 20, 2013

    macrumors member

    Okay. New behavior. If I put the mba to sleep clicking the apple logo, it delays maybe 20 seconds before going to sleep. Once asleep, if I close the lid and then wake the mba with my bluetooth keyboard or trackpad I get signal to the tv in clamshell mode normally, but only for about 10 seconds then the screen goes black again.

    Any ideas based on this?

    Just realized there's a mac basics/help section. Should I have posted this thread there?
  8. macrumors 6502

    No good suggestions here, but you can try checking the system log (Application/Utilities/Console, I think the one to view is system.log). That log file tell you things as for example if the computer goes to sleep, what caused it to sleep, when it wakes up, what caused it to wake up and such things. Maybe that can give a hint of why you're seeing that behavior.
  9. macrumors 65816

    well, that in kind of blows my "it's the TV" theory to hell...
    i'm so sorry man, i'm at a loss. it's almost certainly something stupid we're not thinking of.

    i once reinstalled my entire OS on my work computer because i couldn't get the wifi to work for no reason... it was a linux distribution, so the packages and all had to be manually install

    turns out there was a physical wifi switch on the side of the laptop i'd never noticed and inadvertently turned off.

    have you tried taking it into the fruitstand?


    now this is bugging me, i found a story of a guy who had a similar problem to you who found that starting a video game with the laptop open, and then closing it "resolved" this issue...

    i wonder if that would work for you?

    if so, wtf?
  10. macrumors member

    wtf indeed. I fixed the problem this afternoon. I finally found my mdp to hdmi adapter and plugged it in to the tv that way. Clamshell mode works. Then I unplug it and try the vga cable again and TADA! Clamshell mode works. Don't know why, just glad it's working again. At least I can now use my mba much more efficiently in extended desktop mode than I could before. :D
  11. macrumors 65816

    glad i could help - if only to send you positive thoughts and not any actual help:p

    congrats :0

Share This Page