Command to "choose" via terminal

Discussion in 'Mac Basics and Help' started by bananataffy, Dec 25, 2012.

  1. macrumors member

    Joined:
    Dec 18, 2012
    #1
    so i have this java shell that i'm running via terminal, and it's giving me an option to "choose" from option [1], [2], and [3]. It leaves me at the ":" prompt and i'm trying to select any of the options 1-3. entering "1" (without the quotes) or "[1]" doesn't do anything. copying and pasting the entire line, for example "[1] Option 1" doesn't do anything either. i'm clueless here...
     
  2. macrumors 6502a

    Stooby Mcdoobie

    Joined:
    Jun 26, 2012
    #2
    Can you give a specific example or post a screen shot? Have you tried just entering what option 1-3 is?

    For example, say you want to choose option 1.
     
  3. thread starter macrumors member

    Joined:
    Dec 18, 2012
    #3
    it looks like this:

    [​IMG]

    i've tried to choose Door 1 by entering the following (without quotes): "1", "[1]", "[1] Door 1", and "Door 1". None work.
     
  4. macrumors 6502a

    Stooby Mcdoobie

    Joined:
    Jun 26, 2012
    #4
    Try
    (with quotes) or
    Maybe the space is what's throwing the program off. Adding quotes or an escape character before the space might work. Other than that, I have no idea what it could be.
     
  5. Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
    #5
    It's not a terminal issue. It's whatever the developer of the app implemented. It could be anything. A standard implementation would be to type just the number and then hit return. Clearly that didn't work though.
     

Share This Page