Connecting from Leopard to FreeBSD7

Discussion in 'Mac OS X Server, Xserve, and Networking' started by whitehexagon, Apr 26, 2008.

  1. macrumors regular

    whitehexagon

    Joined:
    May 12, 2007
    #1
    I'm really having some problems connecting these two boxes. I had sftp kinda working for a while, at least small text files, big files seemed to get created at 0 bytes.

    But what I'm really trying to get working is NFS or possibly even SMB so that leopard can read/write to the freebsd box.

    This is as far as I got so far for NFS:

    mac user is id is (peter)501, staff 20
    I created a user on bsd box id is (zfs)501, staff 20
    I have an /etc/exports entry for:
    /data/shared -mapall=zfs -alldirs -network 192.168.0.0 -mask 255.255.0.0

    osx box: 192.168.0.44 (connected 1000Mb to a dlink dir 655)
    bsd box: 192.168.1.39 (connected 100Mb to a netopia router)
    I have a network cable going from one router to the other.

    a showmount -e on bsd gives:
    Exports list on localhost:
    /data/shared 192.168.0.0

    From osx I try to 'connect to server' using the following:

    nfs://192.168.1.39/data/shared

    which eventually results in:

    "could not connect to server because the name or password is not correct"

    Any help would be really appreciated!

    cheers

    Peter
     
  2. macrumors 68000

    oblomow

    Joined:
    Apr 14, 2005
    Location:
    Netherlands
    #2
    add nfs_reserved_port_only to NO in /etc/rc.conf on your bsd box
    and restart the services

    but why don't you install samba on the bsd box, saves you the trouble from mapping accounts (on both machines). And it's much safer since nfs ( version < 4) uses client side authentication, samba uses
    server side authentication.
     
  3. thread starter macrumors regular

    whitehexagon

    Joined:
    May 12, 2007
    #3
    I tried that now, but still no luck on the NFS side.

    I tried again with the samba now, I tried a couple of howto's but something is still not correct. Tried swat, but writing back any changes seemed to fail. So I edited smb.conf manually and at least I managed to connect :) but only zero byte files are being created, much the same way as sftp.
    Cheers
    Peter
     
  4. macrumors 68000

    oblomow

    Joined:
    Apr 14, 2005
    Location:
    Netherlands
    #4
    perhaps a stupid question, but does the sambauser that you're logged as have sufficient privileges on the directory? Is it allowed to write files, or better is it the owner of the directory?
     
  5. thread starter macrumors regular

    whitehexagon

    Joined:
    May 12, 2007
    #5
    it's the owner, and the directory is 777. two files get created when I try to do the copy:

    ._a.dat rw - -
    a.dat rw -r -r

    both same timestamp and zero bytes.
     
  6. macrumors 68000

    oblomow

    Joined:
    Apr 14, 2005
    Location:
    Netherlands
    #6
    another silly question: did you check the sanity of the smb.conf file using testparm? and does the smb.conf for this specific directory has the writable parameter?
     

Share This Page