Cover Flow Problem(IPOD classic_______)

Discussion in 'iPod' started by Hadi, Sep 28, 2008.

  1. macrumors member

    Joined:
    Sep 20, 2008
    #1
    I bought this IPOD classic from this guy 80gb and it's working perfectly.
    I love the cover flow browser but here is my problem:
    When I want to add an album to my ipod I actually add it to itunes library first and then i drag it into ipod territory! What is happening is that when i go to cover flow every song creates a cover flow by it's own. so lets say i have a Moby album with 12 songs. I end up with 12 separate covers which makes me go crazy cause there is A LOT of repeats. through itunes library i actually select all song from that album name the album so they all have the exact name add a cover photo. in itunes and ipod library its all good but when i go to open it in ipod it's all not what i want it to be.

    any help?
     
  2. macrumors 65816

    Tom B.

    Joined:
    Mar 22, 2006
    Location:
    London
    #2
    First, you should check each album that is doing this to see if the album artist category is correct and the same for the entire album.

    If the album artist category is correct, and the same for all of the songs in an album, but they are still being split up in coverflow do the following:

    1. Select all of the songs in the album, and press Command/Control+I.
    2. Change the album artist to something different, for example, if the Album Artist is Moby, change it to Moby1.
    3. Press OK.
    4. Reselect all of the songs in the album and change the Album Artist back.
    5. Press OK.
    6. Repeat with every other album that you are having this problem with.

    Doing that fixed it for me, however any album that does not have the same artist for every song, even if the album artist is the same, will remain split up in your iPod classic's coverflow.
     
  3. thread starter macrumors member

    Joined:
    Sep 20, 2008
    #3
    thanks man. im gona go ahead and try it now see if it works for me. i hope it should
     
  4. thread starter macrumors member

    Joined:
    Sep 20, 2008
    #4
    Nope

    Didn't work man.
     
  5. macrumors 65816

    Tom B.

    Joined:
    Mar 22, 2006
    Location:
    London
    #5
    Do your albums have the track numbers for each song?
     
  6. macrumors 6502

    Joined:
    Feb 3, 2008
    #6
    Try this: Select all the songs of the album, right click > get info > options tab > say "yes" for "part of a compilation".

    Hit OK, and then change it back to "no" if it isn't a compilation. And make sure the performer and album names are spelt the same for each track.
     
  7. thread starter macrumors member

    Joined:
    Sep 20, 2008
    #7
    no cause like, it's not a one album that im having the problem with. i having it with all of them man.
     
  8. thread starter macrumors member

    Joined:
    Sep 20, 2008
    #8
    you can only do "part of a compilation if you select a single track not a group.
    so that wouldnt really help.
     
  9. macrumors regular

    Joined:
    May 28, 2007
    #9
    You probably have something in some of the other fields in the album's ID3 tags. You can try selecting the whole album, bringing up the Info again and putting spaces in any blank fields just to ensure there's nothing suspect happening there. Then convert the ID3 tag in iTunes to v.3.4 or v.3.3 and it should hopefully lose the ID3 tag problem.

    Tagging as a Compilation is a workaround but it means the album will appear under 'Compilations' which it isn't.

    I found just using a decent ID3 tag editor helped quickly fix any of these dodgy tagging issues - Tag'n'Rename on Windows or Media Rage on Mac.


    And just to be sure to be sure, that you're looking at 'Albums' on the iPod when you're seeing multiple covers.
     
  10. thread starter macrumors member

    Joined:
    Sep 20, 2008
    #10
    And just to be sure to be sure, that you're looking at 'Albums' on the iPod when you're seeing multiple covers.[/QUOTE]

    yes i am. let me try. and thanks again
     

Share This Page