Damn wifi connectivity problems

Discussion in 'MacBook Pro' started by ckeck, Oct 10, 2011.

  1. macrumors 6502a

    Joined:
    Jul 29, 2005
    Location:
    Texas
    #1
    Has anyone found a solution or specific cause of this? I had a 2011 MacBook Pro I bougt back in February when they were released and it constantly disconnected from my home wifi network about every 5-10 min...so annoying!

    Since I've had an iMac and now a 13" Air that work perfect without issue on the same network as well as all my iOS devices. I just bought another MBP to replace the Air...brand new and it's doing the same exact thing. Constantly dropping off the network. Adium goes up and down constantly...browsers start timing out..lose my SSH connections constantly.

    How in the hell has this never been resolved? Any insight/advice/news would be appreciated. I need the MacBook Pro but this is making me want to figure out how to keep and use the Air it's so damn bad.
     
  2. thread starter macrumors 6502a

    Joined:
    Jul 29, 2005
    Location:
    Texas
    #2
    To add insult to injury it works just fine on other networks...just not my home network which runs off a damn Airport Extreme Base Station no less.

    I've restored factory defaults on this and messed with it's settings tons of times as well. No love...and everything else works fine. Just the 2011 model MBP's have the issue.
     
  3. macrumors 6502a

    Joined:
    Jul 5, 2011
    #3
    Good luck. I've been fighting this since one of the firmware updates back in the Snow Leopard days.

    Personally, I think it's a driver issue only resolved with a firmware fix. For that to happen though, Apple needs to track it down. They've pretty much admitted there's an issue though because 10.7.1 tried to address it.
     
  4. thread starter macrumors 6502a

    Joined:
    Jul 29, 2005
    Location:
    Texas
    #4
    Well damn...for what it's worth I've been experiencing this issue since Snow Leopard on the old machine so I tend to agree it's driver/firmware related, not OS related.
     
  5. macrumors 68020

    LizKat

    Joined:
    Aug 5, 2004
    Location:
    Catskill Mountains
    #5
    No, it's the mid 2010 model as well, which I got one of as a refurb in the spring this year, and which promptly went back for a new logic board because it wouldn't charge when it showed up. So maybe I have a 2011 model without knowing it, who knows what they put in there when they received the dead one. I was ticked that my usual assumption that a refurb is a safe bet because of extra QA was proved wrong, too! The thing showed up with a fresh battery but no charging ability and some chip anomalies that caused them to say send it back we're going to replace the power port and logic board.

    Anyway I tried everything to get this WiFi to stay awake. I don't bother any more. Sometimes it's okay for long stretches. When it starts misbehaving I just go get an ethernet cable and plug in (i am doing that right now since losing connection like ten times today in half an hour), or else go fire up the MBA or a mobile device. None of my other stuff ever did this no matter how old or new, and none of it does it now except this MBP. I'm unhappy about it. I was hoping (am hoping) Lion will solve my problem with it but I haven't got around to preparing properly for my grand lion experiment.

    Sorry you are having this issue. Sorry so MANY are having it or have had it. I do not understand Apple's silence for so long with this thing unless they are still researching whether it's a firmware / chip issue or what.

    I realize there could be many causes not related to the MBP per se, across the universe of people with the problem. But all the suggested causes and suggested solutions start to feel like the bad old days of SCSI daisy chains before Firewire existed. We ended up calling it scuzzy-voodoo because it was so difficult to pin down "forever" what in your own particular setup made your scsi-based drives behave or go nuts. Well I think we have WiFi-voodoo with the MBPs!

    At least with the WiFi and MBP, the spinoff seems less consequential than the hassles of having those old daisychained drive data issues reach out and grab you without notice. Exception: I no longer bank or make transactions on a wireless connection using the MBP because I don't like thought of losing the wrapup sometime. I sometimes use the MBA because that one holds WiFi as if it were hardwired.
     
  6. macrumors regular

    Joined:
    Sep 24, 2011
    #6
    Are you running SL or Lion? I assume SL.

    Does it do this on all wifi networks or just at home?
     
  7. thread starter macrumors 6502a

    Joined:
    Jul 29, 2005
    Location:
    Texas
    #7
    On the brand new machine it's Lion but on my other 2011 MBP the same exact issue persisted across Lion and Snow Leopard.

    This issue seems to just be at home but I have not used it on tons of different wifi networks. Ethernet works just fine on the home network as does wifi on my MacBook Air, iMac, iPhone, iPad and various Windows machines.
     
  8. Guest

    garybUK

    Joined:
    Jun 3, 2002
    #8
    I have this issue too on a old 2007 15" it's VERY annoying, especially as the only way to kick it to life again is turning on-off wifi.

    Unfortunately I am not in control of the base station it's happening on but seeing as you are, you could try changing the channel of the Base Station, and also try connecting over 802.11a/n instead of b/g, is there anything nearby like a microwave or cordless phone? sometimes if the router is near a satellite receiver too, this will interfere.
     
  9. macrumors member

    Joined:
    Sep 20, 2011
    #9
    I had the same problem when I first got my 13" mbp a few weeks ago. I bought a new router off of amazon and my problem has been solved. Everyone has the airport extreme router and thinks that since they have an apple router then it can't be the router that is the problem. I bought the medialink wireless n router from amazon for about $50 and it has been amazing. Awesome reviews by everyone who bought it. From the second I plugged it in all devices in my network have run flawlessly. Before I got the new router I could not load a webpage on any browser on my mbp, it showed it was connected but would not load webpages. I know people are looking for a simple fix that doesn't cost any money, this worked for me take it for what its worth.
     
  10. macrumors 65816

    kappaknight

    Joined:
    Mar 5, 2009
    #10
    Has the new EFI update fixed the wifi issues for anyone that's on the early 2011 MBP running Lion?

    I'm still running Snow Leopard here and really don't want to upgrade to Lion, but there are some aspects that I'd like to use like iPhoto via the stream.

    The wifi issue is the biggest opposition though even though I seem to have some issues on Snow Leopard with it as well.
     
  11. macrumors 65816

    sweetbrat

    Joined:
    Jun 17, 2009
    Location:
    Redford, MI
    #11
    I had been having problems, but between 10.7.1 and the EFI update everything seems to have gotten sorted out. Not sure if others have had the same results, but my wifi works fine now.
     
  12. macrumors newbie

    Joined:
    Aug 5, 2012
    #12
    http://gadget-mag.com/medialink-wireless-n-router-new-design-w-internal-antenna/

    Medialink Wireless N Router is the perfect solution for adding a wireless network to your home or business. It fully complies with wireless standards and is guaranteed to work with any manufacturer’s 2.4GHz wireless adapter and most manufacturers’ DSL/Cable modems.
     
  13. macrumors 601

    clyde2801

    Joined:
    Mar 6, 2008
    Location:
    In the land of no hills and red dirt.

Share This Page