1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Delay in showing window...

Discussion in 'iPhone/iPad Programming' started by sujithkrishnan, Aug 26, 2008.

  1. macrumors 6502

    #1
    Hi....

    In my am ap, i am not using the help of IB...
    Moreover my first lines in ApplicationDiidFinishedLaunching are to create a window and set a Imageview. But i noticed that most of the sample apps are behaving in such a way that it is showing the first screen when it "zoomed in" while opening the app.
    But for me the app is opening with a black background and showing the image after a small delay...

    Is it bcoz i am not using the IBOutlet views???

    NOTE: I am not using any xib files, all are manually coded...
     
  2. Moderator

    robbieduncan

    Staff Member

    #2
    The view you see when the application first launches (the zoom effect) is not a view: it's a static PNG image that you include in the application to give the appearance of an instantaneous launch. The size and name for this image is in the documentation shipped with the SDK. I suggest you take some time to read it.
     
  3. macrumors 6502

    #3
    Hope it is Default.png

    tnX...
     
  4. Moderator

    robbieduncan

    Staff Member

    #4
    From memory it is. I'm at work so not on my Mac right now and can't check. It's in the documentation so if you do a search in the XCode documentation window for Default.png you should be able to check...
     

Share This Page