1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Desktop & Screen Saver Preferences Unable to Save Custom Folders Correctly

Discussion in 'OS X Mountain Lion (10.8)' started by mfvisuals, Apr 17, 2013.

  1. macrumors regular


    My Desktop & Screensaver preferences pane is not storing changes made to the "Folders" section in the left sidebar.

    If I add a few folders to the list, they remain until I quit System Preferences. After quitting and reopening System Preferences, I'll only see one folder underneath the Photos folder, which is always whichever folder that was selected when I closed System Preferences. After that first change, I can remove all folders, replace the existing folder with different folders, anything really. Then once I quit and reopen System Preferences, I'm back to seeing only a single folder again. Regardless of the folder showing, the actual background image choices I've made for my desktops remain.

    I've confirmed the issue occurs in a second, brand new user account.

    The issue also occurs in a safe boot to any of the aforementioned user accounts.

    I initially tried to remove all user specific .plist preference files related to System Preferences, Desktop, Screensaver, and Display settings, but the issue persisted.

    I tried repairing permission and repairing disk via Disk Utility both while running the OS and also from the Recovery partition. Issue persisted.

    I reset ACLs via the Password Reset dialog in the Recovery partition.
    Issue persisted.

    I ran through several more steps as detailed in the following Apple discussion thread: https://discussions.apple.com/message/21746716#21746716

    Still, the issue persists...

    Another thing to note is that I've been able to reproduce the issue on several other Macs running OS X 10.8 and 10.7, but not all of the Macs are affected.

    This isn't a show-stopping issue, but I'd like to fix it if for no other reason than to prevent it from causing any other issues on my system.

    Any suggestions from the fine folks here at MacRumors?
  2. macrumors regular


    Also, this wasn't mentioned in this thread or the linked thread, but I also tried removing all related preferences files and wiped out the saved application state folder as well, but issue persisted after reboot.

Share This Page