Did my 20" cinema display just die?!

Discussion in 'Mac Accessories' started by hob, Jan 4, 2006.

  1. hob macrumors 68020

    hob

    Joined:
    Oct 4, 2003
    Location:
    London, UK
    #1
    I was just sitting at my computer: the setup is all standard mac stuff, PowerMac G5 - Apple Keyboard/Mouse, 20" Cinema Display. The display suddenly went off. For no apparant reason. I've unplugged it from everything but power, and I can't get it to come back on. The light won't even show. I tried switching the power supply cable with the powermac one. Nothing.

    Any ideas?!
     
  2. mustard macrumors 6502a

    mustard

    Joined:
    Dec 28, 2005
    Location:
    NJ
    #2
    Something to try

    Something like this happened to me a while back and scared the crap out of me but it ended up being nothing. Check to see if the powercable coming from the monitor is tightly plugged in to the power brick - my dog bumped it and it just wiggled loose enough that the monitor went off.
     
  3. jamesW135 macrumors 6502a

    jamesW135

    Joined:
    Apr 30, 2005
    #3
    Acd's just don't DIE they fade then die. Did you see any fading? it could just be a lose wireing job.
     
  4. hob thread starter macrumors 68020

    hob

    Joined:
    Oct 4, 2003
    Location:
    London, UK
    #4
    There were no signs of it going...

    I took the display downstairs to the living room because in my pissed-off state my tiny bedroom was not the place to be thinking...

    I tried two different power-leads into the brick, the one that powers my G5 and the one that normally powers my cinema display. The light on the unit never came on.

    So I think it's probably a problem with the brick. I'm gonna need to pop down to the apple store tomorrow!

    And to think, I used to enjoy going there! I've now officially had every single piece of Apple computer hardware I've ever owned (since I switched 3 years ago) break down on me!! :mad:

    It's a good thing OS X is so good!!
     

Share This Page