1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Disk Utility restore

Discussion in 'Macintosh Computers' started by nitz, Aug 27, 2004.

  1. macrumors member


    One of our computers (G4 Sawtooth) has a hard drive that was on it's way out, making all sorts of weird noises and all that. So before it completely bit the dust I installed a new one and formatted it. I wanted to use the Restore tool in Disc Utility to just copy the contents of the old drive (set as slave) onto the new drive (set as master). I started the comp up from the Panther CD and open Disc Utility. It says right there in the instructions that I can drag the source local HD into the field and then drag the destination HD to the other field and it should do the rest. I can not drag the HD symbol. It won't let me. I tried everything. I am doing something wrong? Am I just misunderstanding the concept? Wouldn't be the first time.
  2. macrumors member


    Anybody? Something "Doo Economics", anybody anybody?

    I tried copying everything over by hand and for the most part it works. There are a few bugs like not being able to activate appletalk in the Classic environment and not being able to see printers in Classic's Chooser. Any tips?
  3. jsw
    Moderator emeritus


    No offense to your abilities intended, just clarifying: you were dragging the named partitions (i.e., "Macintosh HD"), not the disks themselves (i.e., "149.1GB ST3160023AS"), correct? And the new HD was formatted first?
  4. macrumors member


    Thanks for the reply jsw.
    Yes. That is correct. Dragging named partitions and the new HD was already formatted.
    I have found something interesting though. I had taken the old HD out because I thought maybe it was causing errors with disk permissions and file paths. I booted again from the Panther install disc and repaired permissions on the new HD thinking maybe it would help (It didn't). After the permissions repair was done I noticed that I could at that moment drag the disk into the choose restore source field. Thinking, "Aha", that I had to first repair permissions before I tried to drag the disk around, I put in the old HD as slave again and repaired permissions on both.

    It didn't help at all. With two drives in, it won't let me drag either of them. If I take one or the other out and start from CD it will let me but not with both of them in the computer. It doesn't matter if they have the same partition name or not.

    Suggestions? I think I am missing something obvious but apparently it is not obvious enough. Is there a bug in Disc Utility?
  5. jsw
    Moderator emeritus


    Just curious: with the original (failing) drive as the boot drive, can you run Disk Utility from that drive - not the CD? Will it work in that case? It should work the way you're doing it. I don't know of a reason why it wouldn't.
  6. macrumors member


    Hey!! I was just writing to say that I was trying that just now and it seems to work. Great minds think alike. I just hope the old HD doesn't crap out right now. Thanks for the tips. I'll let you know what happens.

  7. macrumors member


    I finally got it to work while running Disc Utility on the failing HD. It took 2 trys. The first time I got some sort of disc error. The second time I clicked the "Erase Drive Contents" box and left the check sum on. It worked like a charm. Everything in X and 9 classic works fine for the most part. The only problems after that were a few programs like Quark (surprise surprise) not working right because various folders had wrong permissions settings. I tried to verify and repair permissions but it didn't help. So whenever a problem comes up I just check to see if there is a permissions issue and fix it manually. No biggie.

    Thanks again for the help


Share This Page