Drive will not boot, but can be read from

Discussion in 'PowerPC Macs' started by mccjim12, Nov 14, 2012.

  1. macrumors member

    Joined:
    Sep 23, 2012
    Location:
    Stamford, CT
    #1
    As the title would suggest, I have a drive that was previously in my PowerBook G4. I replaced it with a new one because I would get the 'you need to restart' message when turning the computer on. I bought a firewire enclosure for it and when hooked up to the PowerBook it mounts and can be read from fine. But when trying to boot from it via Firewire the same message appears.

    Any way to repair boot files so that I can clone it over to the new HD and have it be bootable?

    The main problem really is that I have lost my Leopard DVD and the system restore disk containing OS 10.3.x is pretty useless. What's more, I had made an iso of the disc and attempted to burn it to a DL DVD, which I subsequently found out the PowerBook's super drive will not read.

    Hey, if any of this were easy, it would be boring.:) Thanks!
     
  2. macrumors 68020

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Are you saying you were able to boot from the 10.3 disk?
     
  3. mccjim12, Nov 14, 2012
    Last edited: Nov 14, 2012

    thread starter macrumors member

    Joined:
    Sep 23, 2012
    Location:
    Stamford, CT
    #3
    Yeah, 10.3 installed fine on the new drive.

    Also, just now I tried to repair the drive with Disk Utility and got an error message something in the way of: 'the underlying task reported failure on exit'. Doesn't sound promising.

    Thanks.
     
  4. macrumors 68020

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    That just about eliminates a hardware error causing the kernel panic.

    I suppose you've tried booting in safe mode and/or single-user mode.

    It would seem you're going to be on the hunt for a Leopard install disk. From there I would thing you'd be able to use migration assistant to move your data, settings and apps over to the new drive.

    When you get the Leopard install disk, boot from it with the old drive in the PowerBook to run Disk Utility and check the S.M.A.R.T. status of the drive, just to be sure it's safe to use after you're done with your reconfiguration.
     
  5. SuperJudge, Nov 14, 2012
    Last edited: Nov 14, 2012

    macrumors 6502

    SuperJudge

    Joined:
    Apr 2, 2008
    Location:
    The Triangle, NC
    #5
    You might need to repartition the new drive with APM instead of MBR. This is a fairly common issue that's easily overlooked when installing a new hard drive.
     
  6. thread starter macrumors member

    Joined:
    Sep 23, 2012
    Location:
    Stamford, CT
    #6
    Thanks much. Looks like I just have to bite down and spend another $100 or so on a Leopard disk...AGAIN!! :) Thanks!
     
  7. thread starter macrumors member

    Joined:
    Sep 23, 2012
    Location:
    Stamford, CT
    #7
    The new drive is fine, the issue is that the old one is not bootable any longer. Thanks.
     
  8. macrumors 6502

    SuperJudge

    Joined:
    Apr 2, 2008
    Location:
    The Triangle, NC
    #8
    I clearly misunderstood. My apologies!
     
  9. macrumors 68020

    Jethryn Freyman

    Joined:
    Aug 9, 2007
    Location:
    Australia
    #9
    Do you shave access to any system logs of the crashes, or any photos of the screen? Sounds like a hardware failure. Make sure it still happens when you boot up with all peripherals [other than keyboard/mouse] unplugged. I used a USB wireless card that would every so often cause a kernel panic.
     

Share This Page