1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Duplicate items in contextual menu?

Discussion in 'OS X Mountain Lion (10.8)' started by Watabou, Jul 24, 2012.

  1. Watabou, Jul 24, 2012
    Last edited: Jul 24, 2012

    macrumors 68030

    Watabou

    #1
    I've been noticing that I get a lot of duplicate applications when I right click an item and hover my mouse on "Open with".

    For example, if I right click a index.html file, and I open up the "Open with" submenu, I get 10 Webkits(!), 2 Safaris and 2 TextEdits. How do I stop this from happening? I was alarmed at the number of instances of Webkit and I deleted it, thinking that was somehow the problem but nope. I still get duplicate items.

    Here is what it shows when I right click a text file. You can see there are duplicates. It's very annoying especially if it's some common filetype like an image. I get a very long list.

    Edit: Oh and I did a clean install of ML. Even a restart doesn't fix the issue.
     

    Attached Files:

  2. macrumors newbie

    #2
    Any chance you've experimented with folder hard-linking (shot in the dark)? I'd run the mdfind command to check if there are other copies hidden somewhere for some reason.

    Code:
    mdfind "AppleScript Editor"|grep .app$
    change "AppleScript Editor" to whatever you want.
     
  3. macrumors 68030

    Watabou

    #3
    No I haven't and the mdfind command only lists one AppleScript app. I only installed ML two weeks ago so I didn't really tinker with the system.
     
  4. macrumors newbie

    #4
    Yep ...

    Yeah, I sometimes get this, usually after I just restored an image backup ...


    But the list usually reverts back to normal after a reboot ...


    You can try these Terminal commands to reset the list (If you are comfortable with Terminal commands ...)

    Code:
    cd /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/

    and then type:


    Code:
    ./lsregister -kill -domain local -domain system -domain user
     
  5. macrumors 68030

    Watabou

    #5

    Thank you so much! That totally fixed the problem! :D
     
  6. macrumors 603

    ECUpirate44

    #6
    I have the same issue, but I am not too familiar with Terminal. I am typing the commands and then hitting enter after each one. Is that the process?
     
  7. macrumors 68030

    Watabou

    #7
    I wouldn't type it out if you're not familiar with the terminal. Just copy and paste those above commands and then hit enter after each one.

    The problem should go away after that.
     
  8. macrumors 603

    ECUpirate44

    #8
    I meant i'm copying and pasting them!
    This is what my terminal looks like after entering the commands separately pressing enter after each.
    Screen Shot 2012-07-27 at 7.47.17 AM.png
     
  9. macrumors 68030

    Watabou

    #9
    Yup it should be fixed now.

    If not, just Option-click the finder and select "Relaunch".
     
  10. macrumors 65816

    #10
    awesome. worked perfectly. thanks!
     
  11. macrumors 68000

    T'hain Esh Kelch

    #11
    Worked for me too, thank you!
     
  12. macrumors 68030

    cmChimera

    #12
    Only problem is after reboot, every application is thought to be opening for the first time ever. Any command to revert this back to default?
     

Share This Page