eMac 1.42Ghz - missing screen resolutions in list - help!

Discussion in 'PowerPC Macs' started by glossywhite, Feb 15, 2010.

  1. macrumors 65816

    glossywhite

    Joined:
    Feb 28, 2008
    #1
    Hi there. I just installed "SwitchResX" (stupidly - IMPOSSIBLE to get rid of! :mad:) and now two of the default eMac screen resolutions are missing in:

    System Preferences >> Displays:

    Please someone, tell me how to rid myself of this crappy software, and also how to get back my default resolutions in SysPrefs - I am losing my mind here!.

    Thanks so much!
     

    Attached Files:

  2. macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #2
    dont know anything about switchresx , have you tried to reset to factory settings under geometry in the screen settings ?
    reseting pram?


    btw switchresx says
    Simply choose the Uninstall item from the "SwitchResX Control" menu in the Preferences application, and all components will be removed.


    or you could try it with displayconfigx if the above does not help , i used it to give my eMac the resolution of the external monitor (screen spanning ) 1280x1024 but was not ideal so i lowered res again to 1024x768 on both
    http://www.3dexpress.de/ dont worry english language available
     
  3. thread starter macrumors 65816

    glossywhite

    Joined:
    Feb 28, 2008
    #3
    Yes I tried the so-called "help" on their site, but there is no option to uninstall - I later found you have to use the installer package to uninstall it :rolleyes: so zero stars for their "FAQ".

    I also tried geometry settings to default - no joy :confused:

    [EDIT] I even did a safe boot, but the resolutions are STILL MISSING!. Help! :(

    I also tried CMD-OPT-P-R and then:

    reset-nvram
    set-defaults
    reset-all


    in open firmware, and it still didn't fix it!.

    I am getting a bit pissed now tbh.
     
  4. macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #4
    ah i forgot one thing

    1 uninstall whatever is to uninstall in both programs (resolution settings ) then both programs in the trash and empty trash and restart , no changes yet you will still have the programns resolutions as options ,dont worry,
    now
    go in "finder" macintosh hd (or how you called it)
    go in system
    go in library
    go in displays
    go in overrides
    delete all with the dates that match the install of switchresx and displayconfigx (do NOT delete "overrides" folder itself )
    (need to be admin with password in order to delete )
    and your native resolutions should be back after restart
     
  5. thread starter macrumors 65816

    glossywhite

    Joined:
    Feb 28, 2008
    #5
    Argh - I deleted the sub-folders of /System/Library/Displays/Overrides that corresponded to today's date - I guess I should have expanded them, and removed the individual FILES within them?.

    I'm not blaming you, but one of the original resolutions is still missing, and I didn't find your post to be particularly accurate, but never mind.

    Thanks for trying :)
     
  6. macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #6
    oh :(

    just one thing ,ok a bit late now, but for the future get a external firewire harddrive
    make a backup with carbon copy cloner of your harddrive , after you reinstalled your system and apps , so it does not need to be a 1tb drive a small one depending how many apps and personal files you got will do the job
    that way you got a working backup, which you can always use
     
  7. thread starter macrumors 65816

    glossywhite

    Joined:
    Feb 28, 2008
    #7
    I've been making DMGs for years, and yes, I should have done that - isn't hindsight annoying?!.

    Fwiw, I don't see what all the fuss is about with CCC - I've always used Disk Utility, either from OS X or from the DVD; same outcome - a DMG of my Mac :).
     
  8. macrumors 68040

    MacHamster68

    Joined:
    Sep 17, 2009
    #8
    ccc makes a exact copy a bootable one , means you can direct boot from the copy on the external drive, or in other words you could experiment with the external osx while the internal stays untouched
     
  9. thread starter macrumors 65816

    glossywhite

    Joined:
    Feb 28, 2008
    #9
    ... as does Disk Utility.
     

Share This Page