emacs in leopard

Discussion in 'Mac Programming' started by waterskier2007, Oct 31, 2007.

  1. macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    White Lake, MI
    #1
    I have Leopard installed, and I have developer tools version 3.0, from the apple developer website. I am trying to run emacs to edit a file (sawTooth.cpp) i was able to do this in tiger with xcode tools 2.4, and now it doesnt work. i know that sawtooth is a good file but here is the error i get

    baits-209-93:engin101 brendankirchner$ emacs sawTooth.cpp
    Fatal malloc_jumpstart() error


    can anyone identify thi and tell me what i am doing wrong

    thanks
     
  2. macrumors newbie

    Joined:
    Oct 22, 2007
    #2
    same problem here. wasup?
     
  3. thread starter macrumors 68000

    waterskier2007

    Joined:
    Jun 19, 2007
    Location:
    White Lake, MI
    #3
    pissin me off

    its not that it doesnt recognize the command, its that it has some fatal malloc_jumpstart error
     
  4. macrumors newbie

    Joined:
    Oct 22, 2007
    #4
    It got pointed out to me that my version of emacs is the Tiger version even though I upgraded my computer to Leopard. So I am going to try and resintall the BSD portion.

    check your version with the command:

    emacs --version

    Tiger Version: Emacs 21.2.1
    Leopard Version: Emacs 22.1.1
     
  5. macrumors newbie

    Joined:
    Oct 6, 2007
    #5
    I just upgraded to Leopard and emacs didn't get upgraded. I still
    have the 21.2.1 version. This sucks how many other programs are
    left out like this. I got the free upgrade disk, is it possible to do a clean
    install with that. If not how do I just reinstall the BSD portion?
     
  6. macrumors newbie

    Joined:
    Oct 22, 2007
    #6
    I dunno trying to figure that out myself. I am also curious what other BSD tools didn't get upgraded. I really don't want to download the GNU emacs source and remake the program.

    help me
     
  7. macrumors newbie

    Joined:
    Oct 6, 2007
    #7
    I tried compiling the GNU emacs 22.1 source code but it doesn't compile.
    I read on some other forum that it compiles fine on clean installs. Looks like Apple left some tiger bread crumbs with Leopard Upgrade.

    Let me know if it compiles for you.
     
  8. macrumors 68020

    Gelfin

    Joined:
    Sep 18, 2001
    Location:
    Denver, CO
    #8
    FWIW, this isn't a universal issue. My emacs version upgraded as expected. Have you ever built emacs for a previous OS version? Did you try 'which emacs' to make sure you're getting /usr/bin/emacs? Do you have more than one versioned subdirectory, perhaps, in /usr/share/emacs?

    If none of the above gets you anywhere, make sure the new BSD package was even installed/updated during your upgrade. Apple has changed the receipt stuff from a bunch of bundles to a database, so your BSD.pkg receipt will still be for Tiger. To find the version of the currently installed BSD package, go to a command line and do this:

    Code:
    % [B]sqlite3 /Library/Receipts/db/a.receiptdb[/B]
    SQLite version 3.4.0
    Enter ".help" for instructions
    sqlite> [B]select vers from pkgs where pkgid = 'com.apple.pkg.BSD';[/B]
    10.5.0.1.1.1192168948
    sqlite> [B].quit[/B]
    
    The 10.5.0.1.1.1192168948 bit is what it ought to return. If you don't have the Leopard BSD package installed, you'll just return to the "sqlite>" prompt with no output at all.

    If it wasn't installed, you can probably go back to the install DVD and find and run BSD.pkg directly.
     
  9. macrumors newbie

    Joined:
    Oct 22, 2007
    #9
    From my computer root account:

    sh-3.2# sqlite3 /Library/Receipts/db/a.receiptdb
    SQLite version 3.4.0
    Enter ".help" for instructions
    sqlite> select vers from pkgs where pkgid = 'com.apple.pkg.BSD';
    10.5.0.1.1.1192168948
    sqlite> .quit


    On the Apple UNIX forum someone suggested I reinstall the BSD package from the Leopard DVD.
     
  10. macrumors newbie

    Joined:
    Oct 22, 2007
    #10
    Solution from 'Brian P. Campbell' over at the apple.com Forums

    sudo mv /usr/bin/emacs-i386 /usr/bin/emacs-i386.backup
    sudo /usr/libexec/dumpemacs -d
    emacs --version
    emacs

    ---------------
    Apparently our older version emacs has a newer build date then the version that installed with Leopard. so emacs didn't get updated. i guess.
     
  11. macrumors newbie

    Joined:
    Oct 6, 2007
    #11
    I also saw this fix at apple.com. It fixed my emacs problem.
     
  12. macrumors newbie

    Joined:
    Aug 5, 2003
    #12
    Of course, if you're having this problem on a PPC machine, replace the emacs-i386 in the commands with emacs-ppc

    Yeah, there's a post-install build phase that needs to happen, but if the date of your installed Emacs is later than the date that Leopard was build (October 11), that phase doesn't get run. This is a bug, and I'll file a Radar with Apple about it.

    (btw, I'm the Brian P. Campbell from the Apple forum)
     
  13. macrumors newbie

    Joined:
    Nov 28, 2007
    #13
    same issue on a PPC

    I have an Aluminum Powerbook G4, and I am getting the same error message after having downloaded the October 24th Tiger update and since then upgraded to Leopard. I tried the following commands:

    mv /usr/bin/emacs-ppc /usr/bin/emacs-ppc.backup
    sudo /usr/libexec/dumpemacs -d


    No dice. Running emacs-ppc works fine, but I'm not sure how to make the regular emacs work. Thanks!
     

Share This Page