"error code -50" when transferring files between Mac & NAS

Discussion in 'Mac Accessories' started by E3BK, May 15, 2012.

  1. macrumors 65816

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #1
    I'm not really sure where to look at this point so hoping you good folks can help me figure out what the problem is.

    I have a Synology box with 1TB Caviar Black in it. The setup is about 6 months old. It's been reliable and I can't believe I've waited so long to get one.

    I made the mistake of moving an old iPhoto library onto it. I don't access it often as I use mainly Aperture at this point. As many do when you try to access an iPhoto library on a non-Mac OS formatted drive, it's slow as molasses. I'm just trying to move the file back to my Mac so I can import them into Aperture but ket getting "The operation can’t be completed because an unexpected error occurred (error code -50)."

    I thought I'd try to attach a drive directly to the NAS and transfer that way but same message. every setup I've tried gives the same message. I've tried turning off Time Machine as it seemed to have fixed the problem for some in the google searches I did.

    So I checked to see if it happens with other files and it does :( Any file transfers I try to make gets that error. Does anyone have any idea what this could be or how to fix w/o me losing everything?
     
  2. macrumors 6502a

    Joined:
    Mar 19, 2012
    #2
    What does Synology tech support say?

    Has nothing to do with the format of the disk. You may lack network tuning, or since this is an iPhoto library, perhaps a lot of small file random IO as JPEGs tend to be a bit smaller, and thus performance suffers. For large files, it should perform as well as FW800, assuming everything is GigE from NAS to computer, including router/switch and cables. It's common for people to use Cat 5e for GigE which gives a 1000mbps connection but not performance. You really need Cat 6 for GigE performance, and the runs need to be done correctly: not too long, not too many or too tight turn, not near power lines or ballasts, not pinched under a sofa or desk or under a staple or tack.

    This is a Finder error? You're using AFP to mount the volume?

    This doesn't make sense. How exactly are you "transferring" the data using the NAS user interface from its internal storage to attached external storage? You could not get the same error message from the NAS software since it's not Mac OS.

    Are you sharing the externally attached drive and doing the copy from your Mac? You should realize that this, in effect, copies the data to the Mac and then back to the NAS so naturally you'd get the same error.

    Presumably the Synology software has a command line interface, so you could use its OS to file copy from one disk to another directly - worst case scenario.

    You could also try NFS and see if that works. But the real question is what the error means and why you're getting it. I have no idea what -50 translates into.
     
  3. thread starter macrumors 65816

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #3
    I've not heard back from them yet.

    For iPhoto, it does. The iPhoto library doesn't play well on drives that aren't mac os extended (journaled) format. That's well documented. I moved it to the NAS as backup, not for regular use. Other files used to transfer fine, including my Aperture library.

    It is. Cable is 10 ft long.

    Yes and yes.

    The Synology box has 2 USB port that you can connect external drives to for additional storage.

    Not sharing but it is physically attached to the NAS via USB but I use Finder to view files, drives, etc.

    This is my hell right now. I can't figure it out.
     
  4. macrumors 6502a

    Joined:
    Mar 19, 2012
    #4
    That's not reassuring. Call them tomorrow. The whole point of buying a NAS instead of building your own with FreeNAS or NexentaStor is to have support in cases just like this. If you're going to be on your own in forums, you could be on a FreeNAS or Nexenta forum asking these questions, not having paid for the software.

    I haven't seen this documented. Do you have a reference? I see a number of how to's on putting the library on network storage. None mention this well documented issue. And besides, it's just data, the vast majority of which are JPEGs which don't have any sort of metadata requirements that take advantage of HFS+ forks. And you realize that journaling is just a way to make fsck faster, that's it, right?

    This makes exactly zero sense. Please explain EXACTLY how you're doing this.

    For the Finder to see USB disks attached to the NAS, which in turn is only accessible over a network, you must be accessing the USB disks through the Finder via AFP which means you've shared the USB disks just like the NAS's internal disk.

    What happens if you change the name of the file to something like "doggy"? Do you get the error message when changing it? If not, can you now copy it without error?
     
  5. macrumors 6502a

    Joined:
    Mar 19, 2012
    #5
    And what version of DSM on the NAS are you at? It appears 3.2 might be a minimum necessary version. Possibly 4.0. That's a conversation with Synology though.

    And what version of Mac OS X?
     
  6. macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #6
    What happens when you use File Station to access the file? Are you running the latest DSM?
     
  7. thread starter macrumors 65816

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #7
    dsm 4.0
    os x 10.7.4

    ----------

    Yes, running DSM 4.0. I tried using file station last night as well it looked like it might work so I let it sit overnight to transfer. But this morning, the "copied" file has 0 bytes so it didn't work. I don't see any error messages in FS though.

    ----------

    https://discussions.apple.com/thread/2259633?start=0&tstart=0

    https://discussions.apple.com/thread/2397680?start=0&tstart=0

    There are other references if you google. I'm not trying to be rude or anything and I appreciate the help but this is a known issue w/ iPhoto Libraries.

    Well then the USB drives are shared.
     

Share This Page