Exchange Calendar not syncing

Discussion in 'iOS 7' started by filmfanatic24, Jun 13, 2013.

  1. filmfanatic24, Jun 13, 2013
    Last edited: Jun 13, 2013

    filmfanatic24 macrumors 6502

    Sep 5, 2007
    When I make changes in Outlook to my Exchange Calendar I'm not seeing them show up in iOS7. Do I need to enable push or is there a way to manually update? I restored from a backup and all my settings are the same (I'm getting email and notes just fine).

    Ok, after adding an event from my phone to the exchange Calendar I saw the new events pop up. I was able to delete from the phone and saw them disappear from my Outlook. It seems like my phone isn't checking for changes and I can't seem to find any settings that would be preventing it.
  2. fivedots macrumors 6502a

    Jun 29, 2011
    Not sure - but Exchange push email was not working well for me on iOS 7.
  3. filmfanatic24 thread starter macrumors 6502

    Sep 5, 2007
    Hmm, ok, may just be a bug. I don't use Push for email, I just do a manual check to help preserve battery.
  4. GreyOS macrumors 68020

    Apr 12, 2012
    Known issue for iCloud calendar, perhaps Exchange too. Report the bug?
  5. robwilson macrumors member

    Jan 19, 2012
    Interesting, I am not seeing any of from work coming like a charm and my calendar is working as well.
  6. filmfanatic24 thread starter macrumors 6502

    Sep 5, 2007

    There used to be a place in Settings where you told the OS, for each account, if you wanted push, sync every x minutes, or manual. I can't seem to find that anymore. Wondering if that isn't part of the problem.
  7. deuxani macrumors regular


    Sep 2, 2010
    I have the exact same problem. I think it's not a problem with Exchange, but with every calendar that is synced manually. I have sync set to manual and normal behaviour in iOS 6 and before was that only if you open mail, contact/phone or calendar, the information would be synced. This still works the same in iOS 7 for mail and contacts/phone, but not for calendar.

    The only way to get it to sync is to create a dummy appointment on your iPhone, which forces the calendar to sync. After that just delete the dummy appointment.

    Also, scrollen in list/event view in the default calendar app or Fantastical or Event Book, etc is really slow and choppy.

Share This Page