1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

external drive, unable to reformat

Discussion in 'MacBook' started by dexykat, Aug 3, 2011.

  1. macrumors newbie

    #1
    so i have an external drive, which would normally not be a problem to reformat using disk utility (i am aware of how to reformat a drive im not a complete newbie) so i have a WD 2TB external drive, that for some reason disk utility will not allow me to do anything with it, all options show up grayed or unclickable. it shows up unmounted and says its unreadable, but when i go into disk utility it shows up there. how can i fix this drive? i am running snow leopard on a macbook 2008 (first model of the aluminum body)

    please see attached picture for a more accurate understanding.

    [​IMG]
     
  2. macrumors 68040

    DewGuy1999

    #2
    Try going to the Partition tab, select the number of partitions you want then under Options select the type of partition map that you want then click Apply.
     
  3. macrumors regular

    #3
    Was it previously formatted for a different system? A different (Windows) computer?

    Is it new?
     
  4. macrumors newbie

    #4
    under partitions it looks the same

    [​IMG]



    it was used on this computer before, it just stopped working :( im not really sure what happend... im hoping its not dead. i don't even mind if i loose all the data, id just like to be able to back up my mac again
     
  5. macrumors 68040

    DewGuy1999

    #5
    Does it show up in Finder?
     
  6. macrumors newbie

    #6
    nope, its unmounted, and i can't click mount. it shows up "the disk you inserted was not readable by this computer"
     
  7. macrumors regular

    #7
    Oh this is a fun one. I'm wondering if there is a way to completely "restore" the drive to its original settings....

    Have you tried seeing if it is recognized by other computers?

    That would help to figure out if the problem is Mac specific or specific to the EX HDD,
     
  8. macrumors 68040

    DewGuy1999

    #8
    Do you have the Western Digital SmartWare installed? Can it see the drive? I'm thinking it might be a bad cable or power supply. Any way you can try it with a different cable or with a different computer (Mac or PC)?
     
  9. macrumors newbie

    #9
    i've tried hooking it up to a pc, direct and by pulling the drive out through a cable, the PC doesn't even recognize it. it seems to have power as the light is on? i don't think i have a different cable. i didn't know there was WD software. i can DL it now
     
  10. macrumors 68040

    DewGuy1999

    #10
    Sometimes when the power supplies go bad the drive will light up and make noise but won't spin up and mount as it's not receiving enough power. I don't know if your model has SmartWare (or something else) the newer models do, so it'd be worth checking and downloading if available.
     
  11. macrumors newbie

    #11
    ya so i found the software, installed it and it doesn't even see it, the only thing that does see it is disk utility, which makes me think its getting power.
     
  12. macrumors 68040

    DewGuy1999

    #12
    If you feel like venturing into Terminal you could try this:

    :apple: Mac OS X, Mac OS X Server: How to mount a volume as read-only
     
  13. macrumors newbie

    #13
  14. macrumors 68040

    DewGuy1999

    #14
    Have you looked at the Western Digital Community forums to see if there's anything there that might be helpful.
     
  15. macrumors newbie

    #15
    nothing that i've come across as of yet, i generally can solve problems by using searches and sorting through stuff, but this one has been a stumper...
     
  16. macrumors 68040

    DewGuy1999

    #16
    Still think it might be the power supply. In the past LaCie external hard drives had problems with power supplies going bad and the symptoms were pretty much the same as yours if I recall correctly.
     
  17. macrumors newbie

    #17
    i guess i'll just see what i can do.
     
  18. macrumors regular

    #18
    I hope you can get it worked out. It could be the power supply, but your thinking is that the light is illuminating, indicating the faulty power supply?
     
  19. macrumors 68040

    DewGuy1999

    #19
    My understanding is that when these types of power supplies go bad they will provide some power, like enough for the light to light and sometimes the drive will make noises like it's working, but it doesn't provide enough power to spin the drive all the way up and mount.
     
  20. macrumors regular

    #20
    I trust your understanding of this. However, on the manufacturer's choice, they should have another way of indicating a poor/faulty power supply than just a nearly unnoticeable change. Perhaps a flashing indicator?

    But that's getting off topic a little bit. Do you have it under a warranty or insurance plan of any kind?
     

Share This Page