Facetime over 3g 100% working on ios 4.1

Discussion in 'Jailbreaks and iOS Hacks' started by needuhelp, Oct 10, 2010.

  1. macrumors newbie

    Joined:
    Jul 17, 2010
    #1
    Both my3g and 3g unrestrictor should work,


    1. after install, set Facetime IsDirect flag to on,

    2. go to sbsetting turn off and then back on my3g or 3g unrestrictor,

    3. respring,

    4. turn on wifi but don't need to connect to any connection,

    5. it should works:)
     
  2. macrumors Nehalem

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Facebreak by any chance?
     
  3. thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    #3
    didn't test it yet
     
  4. macrumors newbie

    Joined:
    Aug 6, 2008
    #4
    3G Unrestrictor wont even download for me...keep getting errors. Cydia in general isn't working properly. Just got a 504 Gateway time-out when I tried opening it. Thats about the 10th time that has happened.
    iPhone 4 on 4.1
     
  5. macrumors Nehalem

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    Cydia is getting hit hard. Not much on it is working. Try tomorrow.

     
  6. macrumors regular

    Joined:
    Dec 4, 2005
    #6
    I use My3G... I tried the "direct" flag method, but it just starts to connect and fails. I've heard 3G Unrestrictor works... don't really want to purchase another program that does the same thing if it's going to be fixed soon.
     
  7. macrumors 6502

    Joined:
    Oct 14, 2009
    #7
    Didn't work on 3G unrestrictor, same result as above.
     
  8. macrumors 6502

    Joined:
    Jul 5, 2010
    #8
    I can confirm that 3G unrestrictor is not working.
     
  9. macrumors regular

    Joined:
    Dec 4, 2005
    #9
    At least the devs are working on a fix...
     

    Attached Files:

  10. macrumors 6502

    qpid360

    Joined:
    Apr 23, 2009
    Location:
    Pasadena, CA
    #10
    Worked fine for me earlier. My3G with direct flag on, although it was a bit laggy (which never used to be the case).
     
  11. thread starter macrumors newbie

    Joined:
    Jul 17, 2010
    #11
    Just use 3G unrestrictor to test again, it works perfect, just make sure to turn on wifi but no need to connect to any network, both call in and out are working
     
  12. macrumors regular

    Joined:
    Sep 17, 2007
    Location:
    Santa Clara, California
    #12
    I can confirm that it works under My3G.
    Thank you!
     
  13. macrumors 6502

    Joined:
    Oct 14, 2009
    #13
    Okay this does work on 3G unrestrictor! I just understood what the op was trying to say. So do all of the above on the first post and make sure wifi is on but not connected to any "wifi networks".

    I was turning off wifi to test and this caused it to not work.
     
  14. macrumors newbie

    Joined:
    Aug 4, 2010
    #14
    Facebreak works for me. I had to reset network settings and then it worked.
     
  15. macrumors Nehalem

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #15
    Nice:)

     
  16. macrumors regular

    Joined:
    Dec 4, 2005
    #16
    Works now... I tried the SBSettings "turn off/turn on" step and now I can make FaceTime calls over 3G on 4.1
     
  17. macrumors 6502a

    Joined:
    Oct 27, 2008
    #17
    me and my bro are both on 4.1 and have official apps of 3G unrestrictor and it doesn't seem to work... I get a pop up that says to go in settings and put wifi on...
     
  18. macrumors 65816

    Joined:
    May 21, 2009
    Location:
    Chicago
    #18
    is your wifi on?

    if not, read thread.
     
  19. macrumors 6502a

    Joined:
    Oct 27, 2008
    #19
    well yes and no.... first try I was home so I couldn't leave wifi on or else it would connect to my router.... then I went out and saw this thread so I tried with wifi on and no go still the same pop up Connect to a wifi network to use face time... i even did a reset network settings.... deactivate then reactivate face time, deleted face time in 3G unrestrictor re added it still no go...
     
  20. macrumors 65816

    Joined:
    Jun 13, 2009
    Location:
    Parts Unknown
    #20
    Are you going through all the steps each time?
     
  21. macrumors 6502a

    Joined:
    Oct 27, 2008
    #21
    what you mean? I did all these steps at once... I'm not gonna do all these steps before each calls...
     
  22. macrumors 65816

    Joined:
    Jun 13, 2009
    Location:
    Parts Unknown
    #22
    I meant when you reinstalled 3G Unrestrictor if you performed all of the steps in the first post again.
     
  23. macrumors regular

    Joined:
    Aug 29, 2010
    #23
    Yay! This works for me also. If I have wifi turned on but not connected, then facetime works over 3G with 3G Unrestrictor, and the quality is as good as it was with 4.01. Doesn't work for me if wifi is turned off.
     
  24. macrumors newbie

    Joined:
    Oct 12, 2010
    #24
    facetime sms charge after 4.1 jailbreak

    hi all, I'm new here and have been following the forums.
    I have an AT&T IP4 running 4.1 with preserved baseband 01.59.00.

    I have been using Facetime with no issues for the past 3 months over wifi (also jailbroken for the majority of the time until I upgraded to 4.1 recently). This past Sunday I jailbroke the phone with limera1n and installed 3g unrestrictor. Facetime call is working very well over 3g with "isDirect" option set to yes. However, since then AT&T is charging me an international text message for every single Facetime call I make, regardless whether i'm on wifi connection or 3g. The Facetime call i've been making is an international number, which has never incurred any sms/ connecting charges before the jailbreak.

    anyone has this happening to them? Could you check your at&t usage and see if you are getting these sms charges.

    thanks!
     
  25. macrumors 6502

    Joined:
    Oct 14, 2009
    #25
    I noticed on the 4.1 update, you can now facetime using an email address. You might want to use that instead.
     

Share This Page