1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Fastest way to add subs on MP4's

Discussion in 'Apple TV and Home Theater' started by DJTaurus, Aug 1, 2013.

  1. macrumors 6502a

    DJTaurus

    #1
    I ONLY want to add soft/hard subs on my mp4s.

    I tried iVI and it took me around 1 and a half hour to convert.
    Then i tried submerge and it said in the beginning around 3 hours so i quit the process.

    Is there any faster way only to add subs (without the grey box in the backgroung)....?
     
  2. macrumors 68020

    #2
    Download an srt from Subscene and add it to the file using Subler. Takes 5-10m.
     
  3. macrumors 6502a

    DJTaurus

    #3
    Ok I DID it but i have other problems.

    The movie after the first minutes it turns black... no image... same happens when i try to forward. Sound and subtitles works fine but no image...?
     
  4. macrumors 68020

    #4
    Never encountered anything like that with Subler. What version of Subler are you using? You have watched the original mp4 to make sure it doesn't do the same thing, right? Very weird. Have you tried redoing it? What was the source of the mp4? Handbrake?
     
  5. macrumors 6502a

    DJTaurus

    #5
    Thats the mp4 movie.

    Screen Shot 2013-08-02 at 12.10.48 AM.png

    Then i open new file with subler and i drag n drop the movie and the srt file. I hit save file as and the procedure starts.... i noticed when the bar hits 50-60% it goes away as it finished....

    Screen Shot 2013-08-02 at 12.11.45 AM.png
     
  6. macrumors regular

    #6
    Did you check the "64 bits chunk offset" when you saved it with Subler? If not try it again with that checked and it should work fine.
     
  7. macrumors 601

    #7
    Mp4tools
     
  8. macrumors 68020

    #8
    Good suggestion!

    ----------

    Possibly even better suggestion!!!
     
  9. macrumors regular

    #9
    I have had Subler corrupt files stored on network drives but never had any problem with local files. Usually, I just open the MP4 with Subler, drag in the SRT file and then save. I also usually add the cover image and metadata with subler so it is in there if I decide to put into a new iTunes library.
     
  10. DJTaurus, Aug 1, 2013
    Last edited: Aug 1, 2013

    macrumors 6502a

    DJTaurus

    #10
    I tried it and happened the same thing.

    1)Then i tried 4 new movies with default settings (no 64 chunk) and all of the worked fine. Do i have to always check 64 chunk?) So it seems the problem happens only with this movie...

    2) I noticed that with this movie when i drag n drop files the other settings->hd->goes to 1080p... i checked it back to No and same thing happened... blank screen after some minutes of playing.
     
  11. macrumors 601

    #11
    I use multiple programs sometimes if one does not work with a video
    So if mp4tools doesn't work , I use subler or mkvtools
    You can use mkvtools for mp4's or Avis
     
  12. Moderator

    Nermal

    Staff Member

    #12
    64-bit chunk offset is only required for files over 4 GB. It's off by default because older Apple devices aren't compatible with 64-bit files.
     
  13. macrumors 68000

    #13
    Subler has corrupted my MP4 files also on attempts to add audio tracks from external aac or ac3 files.
     
  14. macrumors regular

    #14
    What program did you use to create those mp4s? If I can reproduce the issue I might be able to fix it.
     

Share This Page