Firefox and 100% cpu usage

Discussion in 'Mac Applications and Mac App Store' started by cool11, Sep 19, 2010.

  1. macrumors 65816

    Sep 3, 2006
    No matter of what version of firefox I use...(many years now, 2x, 3x, 4x )
    No matter of what addons I use...
    No matter of the versions of addons...
    Regardless of osx version....

    ...Firefox on my mac pushes my cpu to 100% usage!
    I use to have about 20 tabs open all the time, but this is not the case in c2d cpu, I think.

    So, when so many things (osx, addons versions, ff versions) changes, I really do not know what else to search for, in order to make my firefox have a normal cpu usage.

    Does this happens to you too?
    Any idea, whatever, about what to try in order to solve the problem?
  2. Guest


    Sep 7, 2008
    forlod bygningen
    Is there Flash content inside any of your open tabs?
  3. macrumors P6


    Jun 19, 2009
    Where bunnies are welcome.
    Close Firefox. Delete ~/Library/Preferences/org.mozilla.firefox.plist. Open Firefox.
  4. thread starter macrumors 65816

    Sep 3, 2006
    No. I have flashblock addon running.

    I 'll try it. What is supposed to do?
  5. macrumors newbie

    Jan 13, 2010
    Install chrome -> Delete firefox -> Done! ;)
  6. thread starter macrumors 65816

    Sep 3, 2006
    I did it. Problem still persists.
  7. LPZ
    macrumors 65816

    Jul 11, 2006
    Quit Firefox. Open Activity Monitor (in Utilities). In the Activity Monitor window, click on %CPU once or twice until the triangle points down. Now start Firefox and watch that column. If the %CPU number becomes large, click on Firefox in the Process Name column and then click Sample Process. Copy the output and post here, or save output and attach here.
  8. thread starter macrumors 65816

    Sep 3, 2006
    I attach firefox sample process content in the file.

    Attached Files:

  9. LPZ
    macrumors 65816

    Jul 11, 2006
    Do you have a javascript debugger plugin or extension? Is it up to date?

    Try this. Quit Firefox, and then restart it while pressing the option key. This should let you run Firefox in "safe mode", with all add-ons temporarily disabled. Do you still have excessive CPU usage?
  10. thread starter macrumors 65816

    Sep 3, 2006
    I do not have javascript debugger.

    I restarted ff in safe mode.
    I open just a few tabs and cpu burns again.

    Here is the sample process file.

    Attached Files:

  11. thread starter macrumors 65816

    Sep 3, 2006
    My addons are adblock plus, addon compatibility reporter, eortologio greek namedays, extended statusbar, feedback(mozilla), flashblock, igetter, greek-english spelling dictionary, tab mix plus. All in their latests version.

    After all, as I said, it is not a matter of versions of firefox, or addons, or which addons etc.
    All the years, in every possible configuration, my firefox has an 100% cpu load.

    Of course it is the same firefox, I just overwrite with any new version available. But I deleted the .plist file also.
    So what?
  12. macrumors member

    Nov 6, 2008
    what kind of machine are you using? You can download an optimized build for your CPU (intel, intel64, G4 or G5) here:
  13. thread starter macrumors 65816

    Sep 3, 2006
    mbp c2d.
    Do you mean these are stable versions of firefox, all included, no features excluded, just customised for each cpu?

    I have to say that I make firefox and my apps trimmed with xsimmer which throws out all ppc code. So, if lets say 80mb, my is only 40mb(approximate numbers).
  14. thread starter macrumors 65816

    Sep 3, 2006
    I choose a build from
    I have to say that mac now is much cooler. It seems that it is a better option than the official firefox.

    Of course, if minefield means always beta, I don't think that it is a good idea to continually use betas.
  15. macrumors newbie

    Sep 16, 2010
    Great referral. Thanks. I basically stopped using Firefox as my main browser a couple of years ago since it's such a pig on my trusty but rather aged 2005 G4 MacMini. However, when I was using it regularly, there was a lot I liked about it.

    Furbism's page on how to find what type of CPU you have is pretty hilarious. Lots of text there, but really all you need to know is Terminal and the word "machine." Classic...
  16. macrumors member

    Nov 6, 2008
    Those are optimized versions of betas and finals. You can download 3.6 or 4 (still beta)
  17. macrumors newbie

    Sep 16, 2010
    Firefox is Still a PIG!

    Well, I downloaded the Furbism optimized versions of Firefox for my machine, a MacMini from 2005 w/1GB of RAM running 10.4.11.

    As I said before, there's a lot I like about Firefox, particularly the safety and security add-ons you can get. I don't have a lot of extensions or add-ins: Just WebDeveloper, BetterPrivacy, FlashBlock and SearchStatus. That's it. It's pretty lean.

    Now the bad news: Even with this optimized version, Firefox is still a friggin pig. I had 3, maybe 4 tabs open, and the entire application minimized in my dock. IT WAS STILL TAKING over 50% of my CPU.

    All my other applications crept to a near-halt.

    Is there a decent browser for Mac OS X? I can't try Chrome since it's 10.5 or later only. I had been using Opera v9 for awhile; I tried v10 when it came out and it was a joke. Tried to type in a search phrase in the google window and the beachball took over. Took literally 10 friggin minutes to type in one word. So as far as Opera, v9 is the only option for me, but it acts strangely at times; doesn't even open Blogger sites for example.

    OmniWeb was my next browser of choice, but after an initial happy period, it gives me the beachball of death as well if I have 10 or so tabs open.

    Safari has become bloated as well, and even though I turn off RSS, TopList and as many extras as I can, it still is a pig much of the time.

    This MacMini I have should be enough machine to surf the friggin web. You shouldn't need a damn supercomputer to use the internet. Or am I wrong?
  18. macrumors G4

    Jul 17, 2002
    Make sure that you have enough free space on your hard drive. You should have at least 10%--some say 15%--of your hard drive available as free space to ensure that your virtual memory has the headroom that it needs.
  19. macrumors newbie

    Sep 16, 2010
    Thanks. Well, it's an 80 GB internal hard drive on the MacMini. There's still about 30 GB of free space. I mainly use an external 1 TB hard drive for storage. So, it doesn't seem as though that would be an issue.

    The Activity Monitor has a couple daemons that are always running which at times gobble up processor overhead, such as TechToolPro daemon, LittleSnitch, CleanApp daemon and DiskWarrior daemon. CleanApp seems to be the most active of those, but for the most part the daemons are pretty dormant most of the time.

    I'm also getting just plain freezes intermittently during the course of a day. I can be downloading, surfing, playing audio files, whatever, when suddenly everything freezes for 10 seconds, sometimes longer. I can't even get to my Activity Window to see what's gobbling processor overhead. I just have to wait for everything to unfreeze.

    I've done enough diagnostics, permissions repairing, directory structure verifying and repairing to know that nothing is seemingly wrong with my discs. But I still get these freezes and I'm talking about EVERY DAY.

    Is Mac OS X.4.11 such a wimp that it can't handle multiple applications or threads running at once? Is RAM a problem (I have 1GIG, which is max for my machine), or is it something else?
  20. macrumors G4

    Jul 17, 2002
    The only thing that stands out are all of those maintenance utilities that you are running. I would keep DiskWarrior, but dump the rest. I don't know that any of them are causing problems, but they certainly are not helping.
  21. thread starter macrumors 65816

    Sep 3, 2006
    I was happy to use these intel-oriented builds of firefox.
    Unfortunately they have not updated firefox to version 5 yet.
    Are they going to continue this development? Who knows?
  22. macrumors newbie

    May 14, 2014
    Shockwawe Flash pluging

    Hi, I had the same problem. What worked for me was to deactivate the plugin ShockWave Flash installed in Firefox. - you find it under add-ons..
  23. macrumors 6502a


    Sep 27, 2004
    The original post was 3.5 years old. I suspect that whatever problem they had isn't still happening (at least I hope not).
  24. macrumors P6


    Jan 24, 2010
    While this is a four year old revived thread, the OP's problem was he was slimming the Firefox binaries. That cause it to go into a loop. The problem could have been solved by not slimming the binary. This is no longer a problem for any user as Mozilla no longer releases Intell/PowerPC universal binaries as it no longer supports PowerPC.

Share This Page