Folder sharing working on 10.7, but not on 10.8 ?

Discussion in 'OS X Mountain Lion (10.8)' started by dvdpearson, Apr 17, 2013.

  1. macrumors newbie

    Apr 17, 2013

    Since we bought several new iMacs with 10.8, the network folders sharing is not working properly on Windows.

    If I share a public folder on 10.7, it is easily reachable by a PC, however, if I share one on 10.8, it prompts me a username/password.

    Are you aware of this issue ? Is it something I missed ?

    Thank you very for your help, It is very appreciated.
  2. macrumors 603


    This is not an issue with 10.8 nor any other OS X version, this is you misunderstanding OS X and file sharing.

    If the permissions on the folder are set to anything other than Read/write you need to input a Password, you can see in the sharing Preference folder, if you want a shared folder to be shared without a user needing to input any name and password you can do so by setting it up the right way.
  3. thread starter macrumors newbie

    Apr 17, 2013
    Hi Justperry,

    Thank you for the quick reply.

    The wierdest thing is that we've setup the network sharing the same way on all the iMacs we have. But this looks like only our 10.7 is working without a user/pass prompt.

    Our folders are set to R/W for everyone and using SMB.
  4. macrumors 603


    I just tried and have no problem connecting to my Mini which is on 10.8.3 without inputting a password, I even shared the whole Macintosh HD and was not asked for a password if I set everyone to Read/write.
    Must be something wrong there.
  5. thread starter macrumors newbie

    Apr 17, 2013
    Alright, I'll dig a little more and let you know.

    Thank you!
  6. thread starter macrumors newbie

    Apr 17, 2013
    Here are two screenshots of my settings. Sorry for giving you a french one.

    SMB sharing is enabled, same thing for the "Tous" (Everyone) R/W setting.

    Is that something I do not understand or miss ? I'm not that much good at Mac World.


    Attached Files:

    • 1.png
      File size:
      100.1 KB
    • 2.png
      File size:
      131.5 KB
  7. macrumors 6502a

    Feb 16, 2010
    This is a not uncommon issue. There are post about it in this forum. I have it with my new iMac with 10.8.3. The solution is to go into network preferences, and disable, then re-enable SMB sharing. Once done it will stick until the Mac is rebooted.
  8. macrumors 603


    You are doing it the right way, here is what you can do without having to input the Password each and every time.

    If you want to connect to a shared drive and need to input the password there is a box under it to remember the password in keychain, check that box and you should be OK.

    See screenshot below, maybe this is what I have done before so that's why I do not have the problem.

    Attached Files:

  9. thread starter macrumors newbie

    Apr 17, 2013
    Hi justperry!

    Your screenshot seems to be on a Mac Server. Since I'm trying to access to a iMac shared folder from a PC, I do not have any of that window.

    It offcourse prompt me a password when I'm assigning a user to the SMB server.

    Also, I've just tested again the same thing on a 10.7 and everything work fine!

Share This Page