fonts missing from menus with large sets

Discussion in 'Design and Graphics' started by tonyp, Feb 22, 2008.

  1. macrumors newbie

    Joined:
    Feb 22, 2008
    #1
    Has anyone else had problems getting large font sets working in OS X (10.4)? We're using Adobe Font Folio 11, with 2300 fonts, at our company but many don't show up in the menu of certain apps. For example all fonts will show up in Text Edit and InDesign, but many will be missing from the menus in Quark or MS Word.

    The problem isn't corrupt fonts, or corrupt font caches -- we've tried every known fix. It seems to be related to the total number of fonts activated. We think it has to do with the programming interface (Carbon vs. Cocoa) used by some of the older programs.

    A font manager isn't feasible for us because we are working with Quark Server (but regular Quark has the problem too).

    Is anyone else using such a large set of fonts, all activated at once? Do they all show up in Quark and MS Word?

    Thanks!
     
  2. macrumors 65816

    AlexisV

    Joined:
    Mar 12, 2007
    Location:
    Manchester, UK
    #2
    What version of Quark are you using? And are you on OS 10.4.11?
     
  3. macrumors 6502

    Joined:
    Nov 30, 2006
    Location:
    Bedford, England
    #3
    A font manager is suitable. How are you managing that many fonts without one, in the system!?!?!
    Suitcase server combined with Fusion would sort your static set out to all apps.:)
     
  4. macrumors 6502

    jerryrock

    Joined:
    Sep 11, 2007
    Location:
    Amsterdam, NY
    #4
    Upgrading to Leopard improves Font Book's performance. This native OSX application is often overlooked and is a great tool for font management. New feature is Leopard allows "on the fly font activation" leaving memory free until actually needed.
     
  5. thread starter macrumors newbie

    Joined:
    Feb 22, 2008
    #5
    Hi, thanks for the replies. We're using the latest versions of Quark - 7.31 for XPress and 7.21 for XPress server, both on 10.4.11. We plan to try Leopard but we have no reason to expect it will resolve the problem. Font Book works fine for us in Tiger. The problem is specifically in the way certain older apps see the font list (Font Book is not one of the older apps).

    We've run Font Doctor already, and we noticed the problem when Suitcase was installed. Also tried FontExplorerX.

    No matter how they are activated, certain fonts will just not show up in the Quark or MS Word menus.
     
  6. macrumors 6502

    jerryrock

    Joined:
    Sep 11, 2007
    Location:
    Amsterdam, NY
    #6
    It may be a permissions related problem. Are the Quark user and System administrator the same person? Which library contain the fonts in question?
     

Share This Page