Fonts not installing

Discussion in 'OS X Mountain Lion (10.8)' started by allasai, Feb 14, 2013.

  1. allasai macrumors newbie

    Joined:
    Feb 14, 2013
    #1
    I tried downloading and installing 3 fonts from dafont.com since updating to OSX 10.8.2. All of my other dafont fonts are working except for these new fonts.It is saying that the letter characters are hebrew and none of the new fonts are are even showing up in Photoshop. Please help :confused:
     

    Attached Files:

  2. desertman macrumors 6502a

    Joined:
    Jul 14, 2008
    Location:
    Arizona, USA
    #2
    It will be difficult if not impossible to help you without knowing the exact fonts and their download links.

    What does that mean? Who is saying?
     
  3. allasai thread starter macrumors newbie

    Joined:
    Feb 14, 2013
    #3
    Thanks for the response... What I meant when I said "it is saying" is that Font Book is showing hebrew error characters instead of the font's characters, which you can see in the screenshots I've provided.

    Here are the download links for the fonts.

    http://www.dafont.com/vtks-rascunho-errado.font
    http://www.dafont.com/vtks-storm-2.font
    http://www.dafont.com/phorssa.font

    Thanks again for your reply.
     
  4. desertman macrumors 6502a

    Joined:
    Jul 14, 2008
    Location:
    Arizona, USA
    #4
    I downloaded "vtks Rascunho Errado" and have no problems with it in TextEdit. See attached screen shot.

    I suggest to clean your font caches and see whether that helps. A good tool do do this is FontNuke: http://www.macupdate.com/app/mac/21536/fontnuke.

    It would be also good to know what kind of Mac and OS you have and in what application you try to use the fonts.
     

    Attached Files:

  5. allasai thread starter macrumors newbie

    Joined:
    Feb 14, 2013
    #5
    In my first post I mentioned that I am running OSX 10.8.2; when I upgraded to this version is when fonts stopped installing properly. I am on an MBP. I am trying that program you suggested now. Thank you once again for your response. :)
     
  6. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #6

    Attached Files:

  7. allasai thread starter macrumors newbie

    Joined:
    Feb 14, 2013
    #7
    Still not installing properly

    I have tried using FontNuke, restarting, and re-installing all three fonts and they are still showing Hebrew error characters. :(
     
  8. allasai thread starter macrumors newbie

    Joined:
    Feb 14, 2013
    #8
    Frustrated

    Can anyone give me any idea about what to do?? I am a professional designer who needs to be able to install new fonts... Any help is appreciated... thanks!
     
  9. soveet macrumors newbie

    soveet

    Joined:
    Feb 22, 2009
    #9
    Same Problem Here

    I am facing the same issue. I can see three different scripts - hebrew, chinese and arabic. (See screenshots)

    A search led me to this discussion on Apple but has no solution:
    https://discussions.apple.com/thread/2195205?start=0&tstart=0

    As a graphic designer, previewing fonts in Font Book is crucial for me! Any help?
     

    Attached Files:

Share This Page