Force eject?

Discussion in 'Mac Basics and Help' started by ClarkeB, Jun 14, 2005.

  1. macrumors 6502

    ClarkeB

    Joined:
    Jan 24, 2005
    #1
    I put a DVD in my DVD drive and it has been ejected but the disk hasn't come out. I've restarted the computer, tried to put another disk in, etc. Is there any key combo or anything to force eject.
     
  2. macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #2
    Restart and hold down the mouse button.
     
  3. Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  4. macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #4
    It works. It was surprised myself. If you have a stock one button mouse it's dirt easy. Just hold down your button when you restart your machine. A pop up with a warning sign on a dialog box will show up when you restart and asks if you want to eject your disk. On my multibutton mouse I just used the button that's mapped to "Click". It's usually the left button.
     
  5. macrumors 68040

    Macmaniac

    #5
    Here is the sure fire way.
    Restart the computer and hold down Apple-option-o-f
    The computer will boot into open firmware, release the keys when it does.
    Then type eject cd and hit return
    Then type mac-boot to start up normally. That should get the disk out.
     
  6. thread starter macrumors 6502

    ClarkeB

    Joined:
    Jan 24, 2005
    #6
    I got it out with the mouse click method. Thanks!!
     
  7. macrumors newbie

    Joined:
    Apr 6, 2009
    #7
    This worked for me, no restart required:

    Open Terminal and type "drutil tray eject" to eject the disc/tray, and "drutil tray close" to close the tray.
     
  8. macrumors newbie

    Joined:
    Nov 5, 2009
    #8
    Force Quit and Relaunch

    Much easier yet, type command-option-escape to bring up the force quit screen and select the Finder (button changes to relaunch).
    After the Finder relaunched, I could eject the disc. Not restart required!
     
  9. macrumors newbie

    Joined:
    Nov 20, 2009
    #9

    this worked beautifully!!
     

Share This Page