1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Handbrake and Plex questions..

Discussion in 'Apple TV and Home Theater' started by HE15MAN, Sep 12, 2009.

  1. macrumors 6502a

    HE15MAN

    #1
    When I try ripping a movie, it fails with the AppleTV Preset when the only change I make it sliding the constant quality preset up to 65% from 59%. When I keep the constant quality at 59% it works fine, is this normal? This is with the newest Handbrake and SL.

    This is only the second movie I have ripped using Handbrake so I am a noob to it, but the last one I ripped took up around 5GB and I figured the Apple TV preset would be a much more manageable file size. Also, I am doing this on a 3.06 GHz iMac with 4GB of memory, and its saying it will be 4 hours, is that normal?

    Also, when I try to import my movies into the movie portion of Plex, it says no files have been added, and doesnt give me an option to "Add Source" it will only let me "Add Source" under the Videos section..

    Also with Plex, is there anyway to make the mouse more useable? Like be able to actually select things when left clicking on them instead of having to push enter?

    Also with Plex, I watched a youtube video of a guys HTPC setup, and when he opened Plex he had movie covers, reviews and theme music when he toggled between his videos, how do you do that and where do you get the info from?

    Thank you so much in advance for all the help, I really appreciate it ! :D
     
  2. macrumors 6502a

    HE15MAN

    #2
    Handbrake just stopped unexpectedly again. Geesh is it something I am doing wrong?
     
  3. macrumors 6502a

    HE15MAN

    #3
    Process: HandBrake [1961]
    Path: /Applications/HandBrake.app/Contents/MacOS/HandBrake
    Identifier: org.m0k.handbrake
    Version: 0.9.3 (2008112300)
    Code Type: X86 (Native)
    Parent Process: launchd [110]

    Date/Time: 2009-09-12 13:30:35.208 -0400
    OS Version: Mac OS X 10.6 (10A432)
    Report Version: 6

    Interval Since Last Report: 48672 sec
    Crashes Since Last Report: 2
    Per-App Interval Since Last Report: 12830 sec
    Per-App Crashes Since Last Report: 2
    Anonymous UUID: 458CD281-623F-4B2B-8C8E-0ED994EAA01C

    Exception Type: EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000000008e0
    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Thread 0 Crashed: Dispatch queue: com.apple.main-thread
    0 org.m0k.handbrake 0x0000c7ba -[HBController processNewQueueEncode] + 44
    1 org.m0k.handbrake 0x000059bc -[HBController updateUI:] + 1332
    2 com.apple.Foundation 0x9647d9d4 __NSFireTimer + 141
    3 com.apple.CoreFoundation 0x92b40eee __CFRunLoopRun + 6846
    4 com.apple.CoreFoundation 0x92b3ed34 CFRunLoopRunSpecific + 452
    5 com.apple.CoreFoundation 0x92b3eb61 CFRunLoopRunInMode + 97
    6 com.apple.HIToolbox 0x923abfec RunCurrentEventLoopInMode + 392
    7 com.apple.HIToolbox 0x923abda3 ReceiveNextEventCommon + 354
    8 com.apple.HIToolbox 0x923abc28 BlockUntilNextEventMatchingListInMode + 81
    9 com.apple.AppKit 0x95a97b99 _DPSNextEvent + 847
    10 com.apple.AppKit 0x95a9740e -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 156
    11 com.apple.AppKit 0x95a595fb -[NSApplication run] + 821
    12 com.apple.AppKit 0x95a51695 NSApplicationMain + 574
    13 org.m0k.handbrake 0x00002f06 start + 54

    Thread 1: Dispatch queue: com.apple.libdispatch-manager
    0 libSystem.B.dylib 0x96e1510a kevent + 10
    1 libSystem.B.dylib 0x96e15824 _dispatch_mgr_invoke + 215
    2 libSystem.B.dylib 0x96e14ce1 _dispatch_queue_invoke + 163
    3 libSystem.B.dylib 0x96e14a86 _dispatch_worker_thread2 + 234
    4 libSystem.B.dylib 0x96e14511 _pthread_wqthread + 390
    5 libSystem.B.dylib 0x96e14356 start_wqthread + 30

    Thread 2:
    0 libSystem.B.dylib 0x96deea0e mach_wait_until + 10
    1 libSystem.B.dylib 0x96e76c05 nanosleep + 345
    2 libSystem.B.dylib 0x96e76aa6 usleep + 61
    3 org.m0k.handbrake 0x00039c9a thread_func + 170
    4 org.m0k.handbrake 0x0003fc8a hb_thread_func + 74
    5 libSystem.B.dylib 0x96e1bfe1 _pthread_start + 345
    6 libSystem.B.dylib 0x96e1be66 thread_start + 34

    Thread 3:
    0 libSystem.B.dylib 0x96deea0e mach_wait_until + 10
    1 libSystem.B.dylib 0x96e76c05 nanosleep + 345
    2 libSystem.B.dylib 0x96e76aa6 usleep + 61
    3 org.m0k.handbrake 0x00039c9a thread_func + 170
    4 org.m0k.handbrake 0x0003fc8a hb_thread_func + 74
    5 libSystem.B.dylib 0x96e1bfe1 _pthread_start + 345
    6 libSystem.B.dylib 0x96e1be66 thread_start + 34

    Thread 0 crashed with X86 Thread State (32-bit):
    eax: 0x00000000 ebx: 0x01257120 ecx: 0x00000001 edx: 0x00000000
    edi: 0x01839000 esi: 0x96227130 ebp: 0xbfffe868 esp: 0xbfffe830
    ss: 0x0000001f efl: 0x00010246 eip: 0x0000c7ba cs: 0x00000017
    ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037
    cr2: 0x000008e0
     
  4. macrumors 68040

    #4
    Bumping up the constant quality has a significant impact on file size and encoding time. For reference, I have mine bumped to 63% and most of my file sizes range from approximately 1.5 to 3 GB, give or take depending on the movie length. Four hours for an encoding run with the settings you have on you machine sounds about right---I encode using either a 2.2 GHz macbook (4 GB RAM) or 2.0 GHz mac mini (4 GB RAM) and an encode takes about 3 hours at my settings.

    Dropping the constant quality setting a couple % will save you time and space. Try encoding just a chapter or two of a movie at various constant quality settings to see if you notice a significant difference. As you can see, just increasing a % or two really impacts how large your files are.

    As for why Handbrake keeps crashing on you---couldn't say other than before the last Snow Leopard update, Handbrake was crashing for me quite a bit but only when I actually tried selecting a source. Since the update, hasn't crashed once. Have you tried removing and reinstalling it?
     
  5. macrumors 6502a

    HE15MAN

    #5
    I just downloaded it and installed it fresh and for the first time yesterday. Mine doesnt crash until it starts the encoding for some reason :(
     
  6. macrumors 6502a

    HE15MAN

    #6
    OK now Handbrake is working, but the video is scrambled..why must I be tormented like this lol :mad:
     
  7. macrumors regular

    Icewind

    #7
    That sounds like you have ripped a DVD that has a different region setting to what your Mac has. This happened to me, as I have an assortment of DVD's that are not Region 2 (my home region). I grabbed Underworld Evolution and stuck it into the iMac.. started a rip with Handbrake and I ended up with a file that when played back, had big red stripes and boxes and all sorts of weird things displaying on it. I looked at the DVD box and seen that it was a region 1 DVD.. Doh!
     
  8. macrumors 68040

    mscriv

    #8
    Handbrake has a forum of its own where developers will help you out if you are having problems. Look here. I have been having "Handbrake unexpectedly quit" problems with a lot of my videos recently. I downloaded the newest "snapshot" of the program and it is working well so far. Keep in mind a "snapshot" is for beta testing purposes, so there could be some bugs and the developers are wanting you to report your bugs so they can refine and improve the program.
     
  9. macrumors 6502a

    HE15MAN

    #9
    Thanks I will look into those! :)

    Any idea's on the plex questions?
     
  10. macrumors 6502a

    Chris Rogers

    #10
    you can enable the mouse in settings I believe.



    Be sure to name your movies in the same format as IMDB.com When you first setup the folder you need to tell it to check IMDB.com for movie information.

    When you are in Movies hold down menu and select Update Library (must be connected to the internet). Wait a few mintes and you're good to go.
     
  11. macrumors regular

    #11
  12. macrumors 6502a

    HE15MAN

    #12
    I dunno, I think I have a whacked version of Plex or something..All the options and buttons I read that people say to do, I do not see on my screen :(
     
  13. macrumors 6502a

    #13
    Ripit App

    To the OP, I would highly recommend Ripit. Right now it does not have the ability to convert to AppleTV resolution, but I believe iTunes does, yes? If not, this would be my recommendation to you. Sell the AppleTV and get a Mac Mini. That's what I did and I have no codec issues. I'm running Plex on top of it and it is all absolutely amazing. If you're concerned about HDMI, Monoprice has a mini-dp to hdmi converter. If you don't have the money for the mini, I would still recommend Ripit, but maybe hold off. They are currently working on importing dvd's in the native apple tv resolution. It's an amazing piece of software, simple, apple like. Cheers.
     

Share This Page