help changing MTU (max. packet size) using airport

Discussion in 'Mac Apps and Mac App Store' started by QCassidy352, Aug 23, 2004.

  1. QCassidy352 macrumors G3

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
    #1
    I'm unable to send e mail with attachments using my new Verizon DSL (which I am coming to hate, btw). My roommates were having the same problem, and we figured out that the problem was that the MTU (maximum packet size) was set too high (it was at 1500 and needed to be at 1400 or something).

    They were able to change it in System Preferences -> Network -> Built in Ethernet -> Ethernet tab -> configure manually.

    I, however, am using airport, and can't find an equivalent option. Does anyone know how to reduce the MTU using airport?

    thanks.
     
  2. GeeYouEye macrumors 68000

    GeeYouEye

    Joined:
    Dec 9, 2001
    Location:
    State of Denial
    #2
    use ifconfig. I don't know the exact command though.
     
  3. QCassidy352 thread starter macrumors G3

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
  4. rendezvouscp macrumors 68000

    Joined:
    Aug 20, 2003
    Location:
    Long Beach, California
    #4
    How big are the files? I have Verizon DSL hooked up to my Airport Extreme and haven't had problems (I've sent files upwards of 800 MB's).
    –Chase
     
  5. bearista macrumors newbie

    Joined:
    Aug 23, 2004
    Location:
    United Kingdom
    #5
    Open a Terminal window and type:

    sudo ifconfig en1 mtu xxxx

    Where xxxx is the MTU, e.g. 1400.

    I have to use 1400 otherwise I can't load any websites using an ADSL connection here in the UK.

    Note that the setting resets every time you reboot the machine (not when you bring it up from sleep though) so you'll have to type it every time you start the machine up... unless you use some sort of script, I don't know lol.
     

Share This Page