HELP! ML won't boot

Discussion in 'OS X Mountain Lion (10.8)' started by bursty, Sep 30, 2012.

  1. macrumors 6502a


    I did a clean install of ML about a month ago, its been running great since. Last night, firefox kept locking up so I decided to just restart everything. It shut down but then froze on the gray screen with the apple logo. It then turns into a circle crossed out, then into recovery mode.

    Disk utility says the drive is fine, so its a problem with ML? Is there anyway to correct this? I could REALLY use some help on this, I am on the road about 8 hours away from my house. Thank you for any help :(
  2. macrumors demi-god


    That sounds like the drive is dying. You can try to reinstall the OS to see if that helps... but this problem is not normal or something that can be fixed by just running a command or anything.
  3. macrumors 6502a


    If the drive was failing, wouldn't disk utility say something? It says everything is fine :confused:
  4. macrumors demi-god


    That message you are seeing means the Mac can't find the OS. Assuming you did nothing to erase the OS, that usually means the drive is faulty.

    How are you running Disk Utility? Start with command-r in Recovery mode and run Disk Util then repair disk and see what you get.
  5. justperry, Oct 2, 2012
    Last edited: Oct 2, 2012

    macrumors 603


    If Disk Utility says the drive is fine the HDD is NOT the problem.

    Don't scare the OP, since he had problems before with software it seems to be the OS itself.

    Try starting up in safe mode, I don't have ML but Leopard and I think you have to hold the shift key while starting up.

    Edit: Just did a quick google search, it says the shift key.

    Edit again: I know you are 8 hours from home but permissions could be the problem, if able to start up in safe mode repair permissions.
  6. macrumors demi-god


    Yeah... thanks for the condescending lecture about scaring people. That was really helpful. Really it was. I just can't express how much I appreciate you straightening me out. :cool:

    That slash message means the machine cannot see the OS. So either the main logic board is bad preventing the computer from seeing the drive at all, or the drive is going bad, or the OS has been deleted/corrupted.

    So now, like I said, unless he just deleted the OS... that leaves the other two causes.

    OP mentioned he ran Disk Util and found no problems. I was trying to understand exactly how he ran Disk Util to assist trouble shooting.

    Safe mode might help... but if the OS is not visible to the machine it likely won't see safe mode either.

    Permissions repair would have nothing to do with OP's problem.

    If you want to offer OP help... that's great. But keep your editorializing to yourself.
  7. justperry, Oct 2, 2012
    Last edited: Oct 2, 2012

    macrumors 603


    Edit: Read My own post and I really don't understand why you say this, there is nothing wrong with what I said.

    I am sorry if I offended you, there is no need to though because I know my way around as well in OSX.

    I fiddled around many times with the system and believe me that sign (circle crossed out) just means it can not start up from the system.

    It has a lot to do with the system and repairing permission CAN 100% make a difference.
    If there is a file with the wrong permissions and the system needs that to be set the way it should be
    there is a big change you end up with just that.

    And I will say it again, his disk is NOT broken, otherwise disk utility would say so.

    Edit 2: The below sign is what I talk about and seen it many times while fiddling with system, after restarting from backup/On other partition and restore what I did it's normal again.

  8. macrumors demi-god


    Alright... fair enough. I am trying to help the guy out and being told to "stop scaring" him struck a nerve. I apologize if I over reacted. :)

    Exactly. We agree. It could be one of the three causes I listed. Just trying to assist OP in eliminating what it could be.

    Here is where we disagree. I agree a root level permissions issue can cause a system not to boot, but that does not just happen all on its own. OP says he was happily buzzing along using his system and it choked so he restarted and went to the slash. Nothing he did would cause a permissions error that would stop a system boot.

    I want more clarity on how exactly Disk Util was run, hence my follow up questions. Ordinarily a software OS issue just does not spontaneously appear like OP described.
  9. macrumors 603


    The both of us are here to help the OP out and the goal is to resolve the issues he has.

    It can have a lot of causes, corrupt files, permissions and yes even a hard disk failure or worse a logic board.
    About the root level, even when it is deeper I think it can prevent the system from loading, lets say kernel extensions or even deeper away.
  10. macrumors 6502a


    Guys, thanks for the advice. I ran disk utility via recovery mode. Thats also how I'm posting, the "find help online" or whatever tab in recovery mode.

    I ran disk util again and got this. So I'm assuming that the drive is going out.


    Really, really ****** timing :mad:
  11. justperry, Oct 2, 2012
    Last edited: Oct 2, 2012

    macrumors 603


    I am still not 100% sure the HDD is fried, how about trying to reinstall in place, so install and archive and look what it does.
    If you have an external and bootable I would start up from that one and recover your Data first.
    I had seen that on My system before and still recovered from it.
    You don't happen to have a bootable Diskwarrior disc, DiscWarrior is better than Apple's own Disc Utility.
    Did you hear strange noises when firefox started vrashing, many times when HDD give up you hear noises, like clicking or screeching.

    In My last post I had an attachment of a picture, was that the one you saw?

    Edit: It says not mounted and the system recognizes the disc so that could be a good sign.
  12. macrumors demi-god


    Ackkk... that does not look good. :eek:

    I agree that looks like a bad drive.

    If you have the ability to do it where you are, the only other thing I can think of to try is from Recovery reformat Macintosh HD and reinstall the OS. Hopefully the reformat would fix the errors on the drive.

    Honestly though, I am not optimistic that will help. If you had done something that precipitated this I would be more hopeful it could be undone, but sounds like you were just using the computer and this happened on its own... and that points to spontaneous hardware failure, the hard drive in your case.

    This crap always happens at the worst possible time.
  13. macrumors 6502a


    I reinstalled and when it restarted I got the same folder with the line through it as posted above. I have no bootable disks/thumb drives with me.

    This MBP is only about a year or two old. It was given to me by my stepmother and when I got it about a month ago, I noticed right away the drive would click occasionally. Didn't think much of it at the time but I guess that shoulda told me the drive was going. Oh well, I'll pick up a new one soon

    I appreciate all the help guys

Share This Page