Help with PowerBook G4: It won't boot

Discussion in 'PowerPC Macs' started by memo90061, May 12, 2013.

  1. memo90061
    Expand Collapse
    macrumors regular

    Joined:
    Jan 2, 2008
    #1
    My small cousin was given a PowerBook G4 laptop, and brought it to me to to connect to the the WiFi. It didn't let me connect, and so I connected the laptop with an ethernet. I tried to update, and figured I had enough time to update it. The battery said there was an hour left, and my cousin didn't have the charger. When it was updating it turned off! Now it doesn't boot. It's stuck at the Apple at the beginning. It's probably corrupted. What should I do now? :/
     
  2. justperry
    Expand Collapse
    macrumors 603

    justperry

    #2
    Try a safe boot, hold the Shift key at startup, but I think it is indeed corrupted, never update without connected to power.
     
  3. memo90061
    Expand Collapse
    thread starter macrumors regular

    Joined:
    Jan 2, 2008
    #3
    I should have known better. -_- O_O

    It's the same and stays at the Apple! Ahhh.

    They don't have the original CDs either.
     
  4. Intell
    Expand Collapse
    macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    What lines does it get stuck at or repeat when you start it up in verbose mode (Command-V)?
     
  5. memo90061
    Expand Collapse
    thread starter macrumors regular

    Joined:
    Jan 2, 2008
    #5
    I fixed it with a Lion DVD disc. haha.

    Thank you. :D
     
  6. skateny
    Expand Collapse
    macrumors 6502

    skateny

    Joined:
    Jul 19, 2012
    Location:
    New York, NY
    #6
    :confused:
     
  7. Cox Orange
    Expand Collapse
    macrumors 68000

    Joined:
    Jan 1, 2010
    #7
    Are you sure you have a PowerBook? Or are you sure it was Lion on the DVD?
     

Share This Page