holding down option key no longer works

Discussion in 'Mac Pro' started by camner, Dec 30, 2013.

  1. camner macrumors member

    Joined:
    Jun 19, 2009
    #1
    I just upgraded recently to 10.9.1 from 10.8.5. I don't know if this has anything to do with my problem, but holding down the option key when restarting doesn't work at all. I get about 30 seconds of a grey screen, then a cursor appears, and nothing happens. I can wait forever and the drives that contain boot volumes do not show up. The only way I can boot off a different drive is to select the new location in System Prefs. This works when everything is fine, but I'm concerned that if anything happens to my boot drive, I'm hosed because I can't seem to get holding down the option key to work.

    Any suggestions?
     
  2. DisMyMac macrumors 65816

    DisMyMac

    Joined:
    Sep 30, 2009
    #2
    Try unplugging all USB and Firewire drives. I had similar problems and that fixed it.

    edit - duh, that doesn't help any. sorry.
     
  3. Anim macrumors 6502a

    Anim

    Joined:
    Dec 16, 2011
    Location:
    Macclesfield, UK
    #3
    Hold option key BEFORE powering on and keep it held until menu pops up?
     
  4. Anim macrumors 6502a

    Anim

    Joined:
    Dec 16, 2011
    Location:
    Macclesfield, UK
    #4
    Also, assuming here you have a time-backup of your system somewhere? as anything boot related is a 'go carefully' area.

    I am not a mac pro user (iMacs and mini's in the past for me) but seem to have found related information to your problem.

    The SMC controller could need a reset.
    ========================
    process:
    1. Shut down the computer.
    2. Unplug the computer's power cord.
    3. Wait fifteen seconds.
    4. Attach the computer's power cord.
    5. Wait five seconds, then press the power button to turn on the computer.

    PRAM reset
    =======
    http://support.apple.com/kb/ht1379

    Permissions might need to be fixed on the drive.
    ==============================


    Anim
     
  5. camner thread starter macrumors member

    Joined:
    Jun 19, 2009
    #5
    Thanks all for your suggestions. Unfortunately, none of them seemed to work.

    However, through trial and error, I DID figure out that the presence of a PCIe Sonnet SSD card seems to be the culprit. When I removed the card, holding down option worked.
     
  6. Anim macrumors 6502a

    Anim

    Joined:
    Dec 16, 2011
    Location:
    Macclesfield, UK
    #6
    Ah nice one. Was that a fully supported SSD for OSX?
     
  7. hfg macrumors 68040

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #7
    That has been discussed in other threads and Sonnet Support has acknowledged that they were able to reproduce the issue and promised a firmware update which never appeared.

    My Sonnet Pro card caused the boot-options to become unavailable ... but for some unknown reason they reappeared again after fooling around with configurations and PCIe card slot locations. Currently I do have boot-options with the Sonnet card installed. I also found that it was the presence of a bootable SSD on the card which caused the issue when I had the problems ... data SSDs were fine.

    Resetting the PRAM caused my system to always boot to OS X, so when I was having the problem, that was my recovery method.

    Good luck, and let us all know if you find a solution ...


    -howard
     
  8. camner thread starter macrumors member

    Joined:
    Jun 19, 2009
    #8
    I also posted on the Apple Discussion board and someone there (before I read your reply) also had an issue with a Sonnet PCIe board. His experience was removing everything and resetting SMC and NVRAM, which I did to no avail. I discovered through experimentation what I learned you had already discovered, which was that the issue seems to be having the boot drive on the Sonnet card. I put the boot drive back where it used to be, in the optical bay with an OWC adapter, and then things are fine. I suspect I won't really notice the difference between having the boot drive in SATA2 rather than SATA3, but even if I do, I'd rather have the ability to get at the boot options.

    Thanks again for the reply.
     
  9. hrandiac macrumors newbie

    Joined:
    May 15, 2006
    #9
    Zapping the PRAM on my Mac-mini restored the use of the option key during a cold start-up.
     
  10. William_si macrumors member

    William_si

    Joined:
    Apr 4, 2016
    Location:
    Graz, Austria
    #10
    heh, that thing. Not really worth the money - it occupies an x4 slot (at least) for 1-2 SSDs at 6Gbit each... buy a Samsung SM951 (AHCI, not NVMe edition) and a PCIe x4 adapter, drop in slot 3/4 and you still come out cheaper than Sonnet+normal SSDs.

    2000MB/s is also a nice upgrade from theory 1200MB/s (in RAID0 on a dual card, else 600MB/s).


    Problem there are dual configs unless you can occupy the other x4 slot also (which will share the BW via a PLX chip, so it's perfect for bootcamp but not for high usage on both) or get a card to split the x16 1/2 slot into M.2 M key (x4 slots) with a PLX chip (around 450$ shipped for a 4x x4 to 1x x16 card, yea.).
     

Share This Page