How do I force external hard drive to be visible?

Discussion in 'Mac Basics and Help' started by McPaul, Mar 5, 2007.

  1. McPaul macrumors member

    Joined:
    Sep 24, 2006
    Location:
    Vancouver
    #1
    I have a My Book by Western Digital, and have never had problems with it. Now I have a new computer and am having periodic problems with the drive not showing up on my desktop or my finder. I have tried power cycling, unplugging the firewire, plugging back in, restarting computer, and nothing seems to work. I have my entire music library on this drive. Any suggestions? Thanks!!
     
  2. PlaceofDis macrumors Core

    Joined:
    Jan 6, 2004
  3. munchmime macrumors member

    Joined:
    Nov 14, 2003
    #3
    Disk Warrior.

    I had this problem before with a lacie drive. I had headaches for weeks, and no one at the time could tell me how to fix it. Then through this website I found out it could be a simple directory problem. Rather than tool around myself at that time, I found Disk warrior could do the job. I tried it, and it worked far beyond my expectations. I know you can get older versions (pre - intel) if you need it still. I'b be willing to sell mine cheap seeing as they are of little use to me now.

    It "diagnosed" the problem, noting that the icon was not on the desktop, and asked if it should repair the directory.
     
  4. McPaul thread starter macrumors member

    Joined:
    Sep 24, 2006
    Location:
    Vancouver
    #4
    good point. No. It does not show in disk utility.

    I tried Disk Warrior with my last machine (pre-intel), it was a help on several occasions. Thanks, I'll search for it.
     
  5. PlaceofDis macrumors Core

    Joined:
    Jan 6, 2004
    #5
    do you have another machine you can try it with?
    have you tried a different port(s)?
     
  6. McPaul thread starter macrumors member

    Joined:
    Sep 24, 2006
    Location:
    Vancouver
    #6
    only one firewire on this mac mini box. I tried the second firewire on the hard drive and ... no dice.

    This seems odd - in disk utility, the mount point for my mini's hard drive shows as "/". This shouldn't be, should it?
     
  7. McPaul thread starter macrumors member

    Joined:
    Sep 24, 2006
    Location:
    Vancouver
    #7
    hmmm, I seemed to have fixed it. when I power cycled the mybook, I noticed that the front lights stayed on. so I unplugged both power and firewire, held for 10 secs, replugged and it showed up.

    weird. anyone know why this occured?
     

Share This Page