1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

How do I use Airport Express with a 2WIRE modem/router (in bridge mode)

Discussion in 'Mac OS X Server, Xserve, and Networking' started by MMM.PWR, Jan 26, 2010.

  1. macrumors 6502

    #1
    EDIT: Figured it out.

    My 2wire router is not the best thing to use with my mac. It works with everything else but sometimes Safari gives me the annoying "you're not connected to the internet." I purchased an Airport Express today and was wondering how do I get to go online with the Airport Express while the 2WIRE is only being used as a modem. Last time I tried I had to call ATT to reset everything because I couldn't manage to get online.

    What information do I need exactly to connect the AE with the modem?

    Thanks
     
  2. macrumors regular

    #2
    I have AT&T with a 2wire modem at home. I run the airport extreme behind it. For me it was enough to simple connect the 2wire with an ethernet cable to the airport extreme, setting up apple's router to bridge mode. That should be really all. Bridge mode means it takes the ethernet connection and DHCP from the router.

    Said this, i still think AT&T's choice to use the 2wire is bad. Not a good modem at all. At least for me.
     
  3. macrumors 6502

    #3
    Thanks for your reply. That's how I have it set up right now too - I will leave it as is and hope my connection doesn't drop again like it did before..

    But I do wonder if this solution is as effective as eliminating the 2wire router completely and use it strictly as a modem.
     
  4. macrumors regular

    #4
    You can ask to have it replaced. I got a second one and it works better. However, you may try setting up DCHP on your Airport and stop DHCP on the 2wire.
     
  5. macrumors 6502

    #5
    How would I do that? I'm new in this field.
     
  6. macrumors regular

    #6
    Like I said I am not sure if this works better, I still recommend to call up your provider and make some generic test to troubleshoot their system or your box. It might be that a new router solves that problem.

    If you have the ATT 2wire you need to go into your HOME NETWORK / ADVANCE SETTINGS, then change your network configuration to manual and set DHCP to off or regulate it to one IP. Either way, I would double check this with your provider to make sure it's all set. I am not sure what your subnet IP is or has to be if you do it manual. Sometimes you need to have also DNS server IPs

    Hope that helps.
     
  7. macrumors 6502

    #7
    This seems to be ok for now. If I have issues again I'll set it to bridge mode or buy a modem that isn't 2wire.
     
  8. macrumors 6502

    #8
    I figured it out. I had set the VCI to 0 instead of 8. That fixed it all.

    I connected via PPPoE and configured the network settings using VHCP.

    Here's 2 screenshots, tell me if something is off.. thanks.
     

    Attached Files:

Share This Page