How to turn off single click to open folders/files

Discussion in 'OS X Mountain Lion (10.8)' started by Trifle James, Apr 5, 2013.

  1. Trifle James macrumors newbie

    Apr 5, 2013
    Hi there,

    I'm new to all this so sorry if I'm doing anything wrong.

    On my mac pro (10.8.2) using my magic mouse, when I double click a folder it opens as you would expect. That's all fine, but after this, it only takes a single click to open the folders or files. This is extremely annoying as I will double click to open a folder, then double click again to find I have accidentally opened a folder and then a file within it which wastes time.

    Is there a way I can turn this feature off?

    Thanks in advance.
  2. Thrash911 macrumors 6502


    Sep 14, 2006
    Randers, DK
    Um.. Is it even possible to configure OS X to open files and folders with single click? I can't figure out how to do it.. :confused:

    Try playing around with the mouse settings, especially the Double-Click Speed (System Preferences -> Mouse). See if that changes anything. Could it be possible, that your mouse is defective? Maybe try with another mouse?

    Other than that, I'm out.. Maybe someone else can weigh in?

    I hope you solve it, because OS X is a delight to use! :)
  3. Trifle James thread starter macrumors newbie

    Apr 5, 2013
    Thanks for the reply!

    Thanks for the reply!

    You're right, I didn't even know that you could configure OS X to do that. It's really weird! I've discovered something else as well, this weird thing only happens if I keep the mouse still. For example, if I double click on a folder to open it and the mouse is already hovering over the new folder I wish to open, it only takes a single click to open the folder as I haven't moved the mouse. Moving the mouse to a different folder means I have to double click.

    You can see why it's so confusing for me!

    I didn't have any joy with the mouse settings and don't have another mouse. But thanks for these suggestions and I agree OS X is great :)
  4. Trifle James thread starter macrumors newbie

    Apr 5, 2013

    By the way, I've just tested this out on my laptop (which has a trackpad not a magic mouse) and have exactly the same issue. So it's definitely something within the OS.
  5. FrankConrad macrumors newbie

    May 29, 2016
    --- Post Merged, May 29, 2016 ---
    I get so frustrated that Apple just changes things, like the single click function, without any option to revert to the older method. Apple just does not listen. Look at the number of people who are trying to find a way to circumvent the inconveniences they impose on their customers. Most people are not computer gurus and are discouraged by having to go through a complete learning curve all the time.
  6. MortalWombat™ macrumors newbie


    I have the same problem. It suddenly appeared and is soooo annoying. How can I get rid of this stupid single click function??

Share This Page