I need help really bad with ios5.

Discussion in 'iOS 5 and earlier' started by sub junkie, Oct 12, 2011.

  1. macrumors newbie

    Oct 11, 2011
    I had been on a beta for ios5, downloaded the official ios5, tried the option restore through itunes, and every time I get an internal error, then my phone tries to reboot, but just goes to a spinning wheel logo. WHAT DO I DO???! I'm about to lose it. I've struggled with iphone updates almost every time. Not to mention that my lock button is broken, so dfu mode is a pita. Please help. I'm so over this lol.
  2. thread starter macrumors newbie

    Oct 11, 2011
    Also, when the restore fails, i get the "connect to itunes" screen on the phone.
  3. thread starter macrumors newbie

    Oct 11, 2011
    My apologies for a triple post, but my internet's messing up at the moment and I cant find the edit button lol. The pictures are all gone from those icons for some reason...

    anyways, the name of the ios5 software that i was on is this: "iPhone3,1_5.0_9A5220p_Restore.ipsw" i don't know if this matters, but every time i try to restore after putting the phone into dfu, it says an internal error occurs, and the phone goes to the "connect to itunes" screen. please help!!
  4. thread starter macrumors newbie

    Oct 11, 2011
    anybody ??? i'm stuck in an endless boot process with the spinning wheel unless i do dfu again, then itunes detects the phone
  5. macrumors regular

    Oct 24, 2010
    Did you update to the latest iTunes?

    Are you sure you downloaded the right ipsw for your phone?
  6. thread starter macrumors newbie

    Oct 11, 2011
    As far as i know, yes, I'm on itunes 10.5
    and yes, the one i'm trying to use is "iPhone3,1_5.0_9A334_Restore.ipsw" and i'm on an iphone 4 AT&T
  7. macrumors newbie

    Oct 12, 2011
    Try putting the phone into DFU mode and restoring to the beta again.
  8. thread starter macrumors newbie

    Oct 11, 2011
    I already tried that actually. I even went back to a beta version of itunes (tried the 10.5 release as well) that I used to install that beta, and it didn't work. I got error code 20, but I cant remember what it said.
  9. macrumors 6502a

    May 26, 2009
    This but instead use the latest software. Search your user folder for *.ipsw to find its location.

    Option or shift click restore in iTunes and select the latest firmware.

    Make sure your hosts file doesnt have anything about apple in it. It would only if you've used something called tinyumbrella. If you don't know what this is then don't worry about it.
  10. macrumors newbie

    Oct 12, 2011
    Hmmm, are you wanting to downgrade to a previous firmware ?
  11. thread starter macrumors newbie

    Oct 11, 2011
    This is what I've been trying, but that's when I get the connect to itunes screen or the endless boot cycle.
    And no, I haven't used tinyumbrella yet on this computer.


    Not unless I have to to upgrade to ios5.
  12. macrumors 6502a

    May 26, 2009
    Do you have any other computers you could try this from?
  13. macrumors newbie

    Oct 12, 2011
    You need to downgrade to 4.3.5 then update to iOs5 through itunes.
  14. macrumors newbie

    May 12, 2010
    i am actually having the same problem! how do you downgrade to 4.3.5?
  15. Guest

    Mar 13, 2009
    Were you an actual developer to get that beta? :rolleyes:
  16. macrumors 6502a

    May 26, 2009
    Might want to fix your internet first. Apple verifies the iPhone software early in the install process and that requires access to their servers via the internet. That may be the reason you are getting an error.

    How long into the restore process do you get before the error occurs?
  17. macrumors 6502a

    May 23, 2009
    Did you try to manually install the IPSW? On an entirely clean slate?
  18. macrumors member

    Jun 18, 2009
    I had same problem as you.

    I had beta 7 installed.
    However I have worked out how to fix this.

    1. make sure you have current itunes 10.5 downloaded and installed from apple.com
    2. Plug you phone into itunes.
    3. Turn phone off properly, by holding top off button and sliding across
    4. Make sure phone is off and plugged in. HOLD power and HOME button for 10secs, till it says connect to itunes
    5. You will see it says DFU mode on itunes. Click Restore.
    6. It will then prompt you to download iOS5 through iTunes. (public version)
    7. Follow onscreen prompts and it will install fresh iOS5.
    8. restore from previous backup

    points to note. Your phone may come out of DFU mode during the DOWNLOAD of iOS 5. Once the iOS5 has downloaded, put it back to DFU mode to restore.

    Took a few attempts because of itunes servers however, successfully running public realise of iOS5 on both ipad 2 and iphone 4.
  19. thread starter macrumors newbie

    Oct 11, 2011
    I wound up calling apple support just to see if they had some quick fix for it, but they didn't. After 35 minutes on the phone and countless failed restore efforts on different computers, the only advice they could give me was to keep trying to install the update, and if it still doesn't work, just to take it to an apple store to have them replace/fix it. Right after the call was done, I tried to install the update one more time, just for the hell of it. IT WORKED. I was shocked lol. Didn't need to do anything. So if anyone is still having problems with the update installing, just keep trying. It actually bricked my phone, let me in an endless boot cycle, and made my phone say "connect to itunes" but it works no, so that's all that matters. lol. Thanks for the help everyone!

Share This Page