1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

iBook G4 Issues

Discussion in 'PowerPC Macs' started by LukeSlade, Jul 26, 2011.

  1. LukeSlade, Jul 26, 2011
    Last edited: Jul 26, 2011

    macrumors newbie

    #1
    Hi, I am relatively savvy when it comes to Macs, however I have never owned a PowerPC before now. I bought an iBook G4 from ebay to have a little look at it and possibly do it up a bit. It is one of the later models released:

    It is running 10.4.11 Tiger
    1.33 GHz PowerPC G4
    512 MB Built in (I have a 1GB expansion on order)
    MATSHITACD-RW
    230GB HDD
    READS DVD: Yes

    I think that's all the info you may need. Basically the first issue raised when I couldn't install anything on the computer because of a password so I used the code:


    Reboot
    Hold apple + s down after you hear the chime.
    When you get text prompt enter in these terminal commands to create a brand new admin account (hitting return after each line):
    mount -uw /
    rm /var/db/.AppleSetupDone
    shutdown -h now

    And made a new account. From there the problems began. When I loaded up safari it said there was a problem with being able to save bookmarks (and subsequently any changes that I made to safari) there was also a problem with Keychain. I searched online and find a few pieces of code which I typed into the terminal, but they didn't have any effect. I also noticed that It wasn't just safari that wasn't saving changes, it was the whole thing. All preferences when I rebooted the system would revert back to default I suppose.

    From here I thought it best to cut my losses and redo the whole system. So I acquired a copy of OS X Leopard 10.5.6 (since this still works on PPC). Originally I tried to do it through USB, but you can't on a PPC. So I used a disk (DVD-RW). This was much more promising. It shows up on the desktop and under 'Startup Disk' in System Preferences so I thought great and restarted to that disk. But when it rebooted it simply rebooted as if I had just pressed restart. Now I must stress that I have tried various methods since (and another disk with a different leopard on it) *both of them are single layer* I tried the old hold down 'C' and hold down 'Option' on startup and tried booting in safe mode, nothing seems to work. I think at the moment it might be best if I try and put Tiger on it again, therefore wiping the HDD and starting again. But the ultimate goal would be to put Leopard on it (especially since I am upgrading / have upgraded the hardware).

    Any thoughts on what I am doing wrong or what I could try?
     

Share This Page