iMessage not working in Messages

Discussion in 'OS X Mavericks (10.9)' started by megalaser, Jun 12, 2013.

  1. macrumors regular

    megalaser

    Joined:
    Nov 17, 2009
    #1
    Installed Mavericks and noticed that my iMessages are offline, I see there is no option to set up iMessages in the message app (a phone number - for text messages) - anyone found a solution? Thanks
     
  2. macrumors 65816

    Four oF NINE

    Joined:
    Sep 28, 2011
    Location:
    Soviet Union
    #2
    I posted in another thread that iMessages is there for me, but is asking for a password which isn't registering for unknown reasons.. not sure what's going on with that.
     
  3. macrumors member

    Joined:
    Apr 4, 2010
    #3
    same issue here, says "could not sign in, please check your network and try again"

    I tried it with and w/o firewall.
     
  4. thread starter macrumors regular

    megalaser

    Joined:
    Nov 17, 2009
    #4
    OK then so maybe I'm missing the fact that before the phone number field appears you need to register an iCloud account in there first, well it asked me for mine, I put in my correct login and password and I just get a spinning wheel.
     
  5. macrumors member

    Joined:
    Apr 4, 2010
    #5
    Maybe I should have logged into iCloud before attempting iMessage, which still forwards SMS your phone receives. I skipped that step when 10.9 booted for the first time.

    Either way, they can't expect us to follow a particular sequence of logging into stuff.
     
  6. thread starter macrumors regular

    megalaser

    Joined:
    Nov 17, 2009
    #6
    signing into Apple ID's to set up iMessage do not appear to be working in Messages in Mavericks.
     
  7. robertpolson, Jun 12, 2013
    Last edited: Jun 12, 2013

    macrumors member

    Joined:
    Feb 24, 2011
    #7
    Found the solution.

    1. Open iMessages

    2. Go to Preferences - Accounts

    3. Choose your apple ID email account and click enable this account

    I am not sure if I had this menu before turning in iCloud off and on again but this worked for me. iMessage now works on Mavericks and iOS 7.
     
  8. macrumors 6502a

    Baklava

    Joined:
    Feb 1, 2010
    Location:
    Germany
    #8
    I can't send and receive Messages via my mobile number. I'm logged in with my iCloud account but my mobile number is not listed under
    Messages > Preferences > Accounts > iCloud Account > You can reached for messages at.
    Any solutions so far?
     
  9. macrumors member

    Kuwait

    Joined:
    Apr 25, 2012
    Location:
    Kuwait
  10. macrumors 6502

    Joined:
    May 7, 2012
    Location:
    Little Rock, AR
    #10
    I think this is one of the things some users will have to wait until DP2 or later to fix and then it will just start working.
     
  11. macrumors regular

    Joined:
    Jun 28, 2008
    #11
    My iMessage works fine. Try to be a little more patient at the spinning wheel after logging on the first time, guys.... It can take up to 5-10 mins.;)
     
  12. macrumors newbie

    Joined:
    May 6, 2008
    #12
    Worked for me

    This also fixed the "Send to iPhone" missing from Maps. I got the beach ball and waited a min. then killed it and reopened. Logged in and all is well.

     
  13. macrumors regular

    Joined:
    Jul 13, 2007
    #13
    Same issue..iMessage is offline, and won't enable

    I've tried to enable my iMessage account, but that option is grayed out and not available. I tried logging out of iCloud, and logging back in, but once I log out it won't log back it at all. Keeps saying to try again later. Now my mail, etc. won't work. Currently doing a restore from Time Machine.
     
  14. macrumors 6502

    gpsouza

    Joined:
    Jan 1, 2012
    Location:
    Lisbon
    #14
    I'm having this issue with DP2, did you solve your problem?
     
  15. macrumors member

    Joined:
    Apr 4, 2010
    #15
    DP2 did not solve it, but I didn't do a clean install.
     
  16. macrumors 6502

    gpsouza

    Joined:
    Jan 1, 2012
    Location:
    Lisbon
    #16
    I guess it was a problem with my number. I've changed my carrier and everything went normal again :)
     
  17. macrumors member

    Joined:
    Apr 4, 2010
    #17
    that doesn't explain why it worked in 10.8
     
  18. macrumors newbie

    Joined:
    Aug 10, 2013
    #18
    It is still not working for me, even with the newest beta. Still get the error message mentioned above... Any recomendations how to reset messages or sth?!:confused:
     
  19. macrumors newbie

    Joined:
    Aug 29, 2013
    #19
    not working for me either

    trying to sign in and it just spins and spins...
     
  20. macrumors newbie

    Joined:
    Oct 17, 2013
    #20
    Hey guys,

    I just figured out how to fix this issue, and it may work for you too. Here's what I did:

    Messages > Preferences > Accounts > your iCloud account tab

    Click "Add Email" next to "You can be reached for messages at:"

    Type in your phone number, hit Enter, and follow the instructions on the screen. It will involve configuring some settings on your phone.

    Hope this helps!!
     
  21. macrumors member

    Joined:
    Nov 15, 2010
    Location:
    Reading, UK
    #21
    Thanks - that worked :)
     
  22. macrumors member

    Joined:
    Nov 21, 2003
    #22
    I am having a similar problem. Yesterday, when I upgraded to Mavericks everything worked fine. Today Messages does not work. When I put in the person's name it appears in red and I am told that I am not signed in to my iMessage account but when I go in to the preferences it shows that I am signed in. I have tried signing out and signing back in, restarting the computer and resetting the NVRAM. Messages is working just fine from my iOS devices and from my iMac but not from my Mac Book Pro. The iMac and the Mac Book Pro are on the same network.

    Any thoughts or suggestions?
     
  23. macrumors 65816

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #23
    try going to:

    System Preferences>iCloud>

    or System Preferences>Internet Accounts>iCloud
     

Share This Page