iMessage, what am i doing wrong!?

Discussion in 'OS X Mountain Lion (10.8)' started by shorn, Jul 27, 2012.

  1. macrumors regular

    Joined:
    Jun 29, 2010
    #1
    Hi all,

    right, just looking for some help. I have iMessage set up on my phone.

    I have it set to my iCloud Apple ID, and it set to receive at 2 addresses. My phone number, and my iCloud email address.

    I have both my iPad and Mac set up in exactly the same way, except just to the iCloud email address.

    I get no messages to iPad or Mac, only to the iPhone.

    Am I being a numpty and doing something obviously wrong?
     
  2. macrumors member

    Joined:
    Feb 15, 2010
    Location:
    Seattle, WA
    #2
    Are people messaging you using your phone # or your e-mail address? If they are doing it using your phone then it makes sense that the devices set up only for iCloud address won't receive the messages.
     
  3. thread starter macrumors regular

    Joined:
    Jun 29, 2010
    #3
    As my phone is set up for both, wouldn't it go to both?
     
  4. macrumors newbie

    Joined:
    Jun 19, 2010
    #4
    I'm experiencing this problem as well. I've read that you should make sure your callerID is set to your email address and not your phone number, however, this did NOT solve the problem for me. Others have said that going to the AppleID website and updating your phone number has solved the problem for them. Again, however, this did not work for me. If anyone has a solution to syncing messages and iMessage for mountain lion users, please post it!
     
  5. macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #5
    Not until iOS 6. For now, messages must be sent to your email address to sync over all devices.
     
  6. macrumors newbie

    Joined:
    Jun 19, 2010
    #6
    Boo. Thanks for your response, but that's disappointing. Is this confirmed for iOS6?
     
  7. macrumors newbie

    Joined:
    Oct 10, 2011
    #7
    have you verified your mobile # with apple? google 'manage apple id'.. log in, and under phone numbers, make sure your cell number is under mobile #, save changes. I did this, and it worked like a charm!
     
  8. macrumors 6502

    The Tuck

    Joined:
    Jun 8, 2003
    #8
    This is not possible yet, and yes. It is confirmed for iOS 6. I'm sure there will be an OS X update at the time to enable phone # messages for the Messages.app app in OS X.

    Tuck
     
  9. macrumors regular

    Joined:
    Mar 15, 2011
    #9
    iMessage seems to be a mess.

    I am trying to add a new imessage account and there is no option to do so! and under iCloud there is no message option either. Very strange.

    Not sure where to go now with this.
     
  10. macrumors 6502

    hNicolas

    Joined:
    Dec 4, 2008
    Location:
    Ottawa, ON

Share This Page