Invisible Underscores in Terminal?

Discussion in 'Mac Apps and Mac App Store' started by mduser63, Feb 2, 2005.

  1. mduser63 macrumors 68040

    mduser63

    Joined:
    Nov 9, 2004
    Location:
    Salt Lake City, UT
    #1
    I've got a question/problem that's been bugging me for a while. Underscores (_) don't show up in the terminal. They just look like spaces. Typing them shows up as a space, but otherwise they work fine. For example, if I have a file called "my_file" and I type "rm my_file" to remove it, it shows up as "rm my file". If I hit enter, the command does work as expected, and copying and pasting from Terminal into TextEdit behaves as you'd expect (that is, underscores transfer over). Any idea why this is happening? It seems like it didn't do this at one time, but I have no idea if I did anything to cause it or when it started. I've attached a screen shot below.
     

    Attached Files:

  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    Do you know if it ever worked correctly, since you changed the colors and fonts? It could be an issue with the font you're using. The default font settings are Monaco regular, 10 pt, width and height at 1.0.
     
  3. mduser63 thread starter macrumors 68040

    mduser63

    Joined:
    Nov 9, 2004
    Location:
    Salt Lake City, UT
    #3
    Thanks for the reply. That was the problem! I was using Andale Mono, and when I switched back to Monaco the problem disappeared. I don't remember changing it to Andale Mono, but obviously I did. Anyway, thanks.
     
  4. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #4
    Glad it helped! It always seems to be something little and random like that. I can't believe there's a relatively major character set that doesn't have the underscore properly defined! :eek:
     

Share This Page