iPad 2: No gyroscope?

Discussion in 'iPad Tips, Help and Troubleshooting' started by midniteriver, Mar 14, 2011.

  1. macrumors newbie

    Joined:
    Oct 23, 2008
    #1
    I tried installing an app on my iPad 2 that requires a gyroscope. When I clicked the buy button from the app store, I received a message saying "The App Is Incompatible With This iPad / This app requires a gyroscope." I know my iPad 2 is supposed to have a gyroscope, so I'm guessing this is a software issue. Any suggestions? I tried other gyro-apps, but got the same result.
     
  2. macrumors newbie

    Joined:
    Mar 15, 2011
    #2
    That's crazy! Mine's doing the same thing... no idea why.
     
  3. macrumors newbie

    Joined:
    Mar 7, 2011
    #3
    Maybe the app hasn't been updated...
     
  4. thread starter macrumors newbie

    Joined:
    Oct 23, 2008
    #4
    I tried several apps, all of which say "Compatible with iPhone 4, iPod touch (4th generation), iPad 2" in the Requirements side section.
     
  5. macrumors 6502a

    Bluemeanie1976

    Joined:
    Nov 1, 2009
    Location:
    Veliko Tarnovo, Bulgaria
    #5
    My ipad1 never came with a gyroscope, however, it did come with a periscope.


    [​IMG]
     
  6. thread starter macrumors newbie

    Joined:
    Oct 23, 2008
    #6
    Well, my iPad 2 came with neither apparently. Seriously, any advice?
     
  7. macrumors newbie

    Joined:
    Aug 17, 2010
    #7
    What app were you trying to install? I'm having the same issue with a couple of my apps.
     
  8. macrumors member

    Joined:
    Oct 24, 2008
    #8
    I'm having the same issue with the jenga app and my iPad 2
     
  9. macrumors newbie

    Joined:
    Mar 17, 2011
    #9
    Got the same issue here

    Seems that many gyroscope apps think the ipad2 does not have one. I have tried:

    gyroscope free
    gyroscope toolkit
    gyroscope surface level
    gyrocompass 3D

    And these all state that they are ipad2 compatible. OK

    BUT What DID work is Cosmic Top - which responds to the gyroscope in fun trippy way.

    So, not all gyro apps - but allot it seems. one of the first on the fix list I guess.
     
  10. macrumors newbie

    Joined:
    Aug 17, 2010
    #10
    Well at least it's not just my apps. I've got two games in the appstore that require the gyroscope (Bullseye Factory and GyroDodge), and I was disappointed to get my iPad2 home and find out that they don't install. However, I was able to remove the requirement and build them on my iPad just fine, so I know the gyroscope works. I'm just waiting on Apple to let me know what we should do about the issue.
     
  11. thread starter macrumors newbie

    Joined:
    Oct 23, 2008
    #11
    I know I tried Gyrorama. I tried several others, but can't remember which.

    So has anyone called AppleCare and gotten an answer? I called them yesterday, and they had not heard about the issue (in fact, the adviser didn't even know what a gyroscope was). He said it had to be elevated to a senior adviser, which would've been "a very long wait." So I'll call back.
     
  12. macrumors 68020

    michael.lauden

    Joined:
    Dec 25, 2008
    #12
    this is probably the funniest thing i've ever seen on macrumors
     
  13. thread starter macrumors newbie

    Joined:
    Oct 23, 2008
    #13
    I activated the advanced 4- and 5-finger multitouch gestures by installing Xcode. Has anyone else with the gyroscope issue done this? I'm wondering if it's related.
     
  14. macrumors 6502a

    KauaiBruce

    Joined:
    Jul 5, 2007
    Location:
    Kauai, HI
    #14
    Wow. Talk about skipping the lead. You should always mention you have hacked your system before complaining something did not work.
     
  15. thread starter macrumors newbie

    Joined:
    Oct 23, 2008
    #15
    Two things: One, it isn't a hack. It's authorized access for iOS dev program members.

    Two, I just discovered they are unrelated. I completely restored the iPad as new, and it still thinks the gyroscope isn't onboard.
     
  16. macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #16
    The word on the rumor sites this morning concerns an update to iOS. Note that it includes a fix for Gyroscope.

    Here are the changes from iOS 4.3:

    - Baseband updates for the 3GS and iPad (original)
    - Fixed memory hang that results in memory corruption when reading large files from USIM filesystem
    - Fixed problem with NTLM authentication in apps and on websites
    - Fixed issue with the Springboard and 3rd party apps not recgonizing the gyroscope on the iPad 2
    - Fixed iPad 2 jailbreak vulneratbility [sic]
     
  17. macrumors newbie

    Joined:
    Oct 13, 2011
    #17
    "This App is incompatible with This iPad"

    It has nothing to do with a Gyroscope! I have an iPad 2 and am just trying to update some Apps (as you do) and they've all updated just fine apart from Keynote and Pages which were both designed for iPad!! I then tried to download the Guardian App and it says that's incompatible too.

    So it must be a cock up at Apple. Any ideas to resolve would be greatly received, although I think this thread has started with a red-herring (or Gyroscope!)

    Tim
     
  18. macrumors newbie

    Joined:
    Oct 13, 2011
    #18
    This App is Incompatible with This iPad

    I'm getting the same message trying to download the updates to Pages, Numbers and Pocket Universe. Any ideas, other than having to travel some distance to find an Apple Store? Thanks.
     
  19. macrumors newbie

    Joined:
    Sep 14, 2012
    Location:
    Sudbury, Ontario, Canada
    #19
    Trouble

    I do not have a iPad2 but gen1 iPad, I have tried to install apps that clearly say they are compatible with the gen1 iPad, but I get the: this app is incompatible with this iPad/ this app requires a gyroscope, I know for a fact that the games do not even use the gyroscope, and that I have played other games that have tilt controls that work, so why is it asking?
     

Share This Page