iPhone gmail IMAP help

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Bernie-Mac, Oct 26, 2007.

  1. macrumors 65816

    Joined:
    Jul 30, 2007
    Location:
    Sin City, NV
    #1
    Hey guys, yesterday I got the IMAP option on my gmail account but everytime I try to set it up like they show you in the video it always says "try connecting without SSL?" so I say yes and it always says it can't connect. Am i doing something wrong?
     
  2. macrumors member

    Joined:
    Oct 26, 2007
    #2
    Go to this link and it explains step by step how to setup IMAP mail in iphone:
    https://mail.google.com/support/bin/answer.py?answer=77702
     
  3. thread starter macrumors 65816

    Joined:
    Jul 30, 2007
    Location:
    Sin City, NV
    #3
    Tried that....it doesnt work, thanks for playing tho
     
  4. macrumors member

    Joined:
    Aug 17, 2005
    #4
    Are you using 1.0.2 or 1.1.1? Lately people, like myself, have had IMAP issues but were fixed in 1.1.1.
     
  5. macrumors member

    Joined:
    Oct 26, 2007
    #5
    Make sure before setting up new IMAP Gmail, delete the old gmail account from iphone;

    try to setup IMAP only after deleting the default gmail one on ur iphone and hope this will solve the issue!!!!!
     
  6. thread starter macrumors 65816

    Joined:
    Jul 30, 2007
    Location:
    Sin City, NV
    #6
    But i dont have another gmail account on my iphone, i just have an aol account, it always says "set up using ssl?" and i say yes and then it says it cant connect to the server:(
     
  7. macrumors member

    Joined:
    Oct 26, 2007
    #7
    Are you using 1.0.2 or 1.1.1?
     
  8. macrumors 6502a

    Flhusky

    Joined:
    Aug 28, 2007
    Location:
    Florida
    #8
    I'd bet they are useing 1.0.2
    I'm having a similar issue where the gmail acct. is doing 1 of 3 things;

    1. NOT saving the imap password after it appears to have been saved in the inital acct. creation. When attempting to access the gmail acct. it says "No password saved, please go into email settings and enabled a password" or something like that

    2. "try connecting without SSL?" when setting up the inital acct.

    3. Connecting to the gmail acct and seeing NOTHING in the inbox, yet i can send mail from that gmail acct and it shows up on line and where ever else I sent it. Responding to that mail causes no action on the iPhone but ti shows up on line.
     
  9. thread starter macrumors 65816

    Joined:
    Jul 30, 2007
    Location:
    Sin City, NV
    #9
    im using 1.1.1

    :edit: nvm got it
     
  10. macrumors 6502

    Joined:
    Sep 23, 2007
    Location:
    Michigan
    #10

    I'm having the same issue and i'm on 1.0.2, is it safe to connect without SSL?
     
  11. macrumors newbie

    Joined:
    Sep 21, 2007
    #11
    What did you do?
     
  12. macrumors newbie

    Joined:
    Oct 26, 2007
    #12
    I'm having the same problem.

    My mail account worked fine for about a week.
    But when i want to check my mail today, it says "No password provided for ..... Please go to Mail Account Settings and enter a password".

    I've tried this about a hour now without getting it to work.

    I enter my password in the settings and return to the "main settings screen".
    I can now enter the mail settings again and the password is still there (displayed with *)

    But when i click the mail icon i get the same message again!
    Going back to the mail settings, and the password is gone. It's just displaying "Recquired"

    It seems like the mail app is wiping out my password!

    Can this have something to do with the "Services" Application from the installer. I used it to turn off edge last night. And switched it on again this morning. And since then mail isn't working anymore.

    I hope someone can help!

    greez, mloewe

    i am using 1.1.1
     
  13. macrumors 6502

    mpuck972

    Joined:
    Aug 31, 2007
    #13
    BTW, this can't be a firmware problem, I was using IMAP on 1.0.2 with no problem whatsoever.
     
  14. thread starter macrumors 65816

    Joined:
    Jul 30, 2007
    Location:
    Sin City, NV
    #14
    I just did it again and it worked, idk i guess maybe you have to wait a few days for the iphone to register that you can use gmail IMAP? Idk but i tried it again and it worked perfectly
     
  15. macrumors newbie

    Joined:
    Oct 26, 2007
    #15
    has anyone else encountered the same "No password provided for..." problem?
    can anyone help?

    otherwise i think i have to restore mit iphone.

    greez, M
     
  16. macrumors newbie

    Joined:
    Nov 7, 2007
    #16
    The best way I've found to set this up is to setup mail with the gmail account for imap, and then sync the account. Bam, it works every time after that.
     
  17. macrumors newbie

    Joined:
    Nov 30, 2007
    #17
    I have the same issue. Does anyone have any fixes for this?
     
  18. macrumors 68030

    CD3660

    Joined:
    Jun 6, 2007
    Location:
    Cheshire, United Kingdom.
    #18
    These are the settings for Gmail on my iPhone, and they work perfectly:
    Incoming Server: imap.gmail.com
    User Name:******@gmail.com
    Password: ********

    Outgoing Server: smtp.gmail.com
    User Name: *******@gmail.com
    Password: ********

    Then, under the advanced settings:

    Incoming Settings
    Use SSL: ON
    Authentication: Password
    Server Port: 993

    Outgoing Settings
    Use SSL: ON
    Authentication: Password
    Server Port: 587

    Hope this helps. :)
     
  19. macrumors regular

    Joined:
    Jul 21, 2008
    #19
    this is what did it for me!
    originally posted by Mike in the comments at Appsafari.
     
  20. macrumors regular

    Cordless_Drill

    Joined:
    Jul 6, 2004
    Location:
    Montgomery, Ala., USA
    #20
    This trick just worked for me as well.

    I have no idea why or how it worked. Oh well.
     
  21. macrumors newbie

    Joined:
    May 16, 2008
    #21
    What worked for me "No password provided" for SMTP on iPhone

    This happened to me after receiving a replacement iPhone 3GS on warranty and restoring all my iPhone data and settings to the new phone. It would probably also happen to you if you did an emergency restore to an earlier backup.

    I tried clearing the CAPTCHA via the link provided but that didn't make a difference. What worked for me was going deeper into the settings for my Gmail account on the iPhone. I realized that even though I had provided the password once, it didn't fill it in for the outgoing (SMTP) server. This is where I found it:

    I clicked on Settings -> Mail, Contacts, Calendars -> Accounts -> Mail Account (mine is @gmail.com) -> SMTP Server -> Primary Server and realized there was an 'optional' password field that had not been filled in yet.

    Once I did this, the mail immediately resumed sending as normal.:apple:
     
  22. macrumors newbie

    Joined:
    Sep 2, 2008
    #22
    Gmail outgoing mail settings grayed out

    I've searched every forum and I can't find an answer to my problem anywhere. I have a gmail imap acct on my newly replaced iPhone 3G. Most of my email accts had to be updated by re entering passwords etc. All are back to normal except for the outgoing mail settings of my gmail acct. When I go in to the smtp settings, all the info is entirely grayed out. The account is turned on, the incoming works fine. My old password is still in the field and all other info is correct (besides the password). But I can't edit any of the info since it's all grayed out. It's turned on but all fields are gray. I tried creating a new outgoing secondary SMTP that was identical and I was able to enter the new password and turned off the original outgoing default but nothing works. Any help?
     
  23. macrumors newbie

    Joined:
    Dec 20, 2009
    Location:
    Elk Grove, CA
    #23
    AppGmail

    I tried it all. Do yourself a favor and download the Gmail application from iTunes. It is called AppGmail. I did that and now am a happy camper.:eek:
     

Share This Page