iPhone time is on "Set Automatically" but with DST today, it's wrong

Discussion in 'iPhone' started by heyyitzmelissa, Mar 11, 2012.

  1. macrumors 6502

    Joined:
    Jan 17, 2012
    #1
    Is anyone else having this issue? Set automatically works fine in my iPad but on my iPhone, it's displaying a time two hours late.
     
  2. macrumors 68020

    Comeagain?

    Joined:
    Feb 17, 2011
    Location:
    Spokane, WA
  3. macrumors 65816

    viewfly

    Joined:
    May 1, 2009
  4. macrumors newbie

    Joined:
    Mar 11, 2012
    #4
    verizon iphone dst setting

    I have a Verizon iphone & it rolled back an hour at midnight instead of springing forward an hour at 2am. I am in the SF Bay area. If I turn off "set automatically" it switches to the correct time. They had this problem last year & it is the first time it's happened to me (have had iphones on both att & verizon) - I'm astonished they haven't straightened this out.
     
  5. macrumors demi-god

    Gav2k

    Joined:
    Jul 24, 2009
    #5
    Wirelessly posted (iPhone 4s: Mozilla/5.0 (iPhone; CPU iPhone OS 5_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B179 Safari/7534.48.3)

    Turn it off. Networks are very poor at updating the time!
     
  6. macrumors member

    Joined:
    Feb 26, 2010
    Location:
    Fayetteville, NC
    #6
    I have my Set Automatically disabled and it still displays my world clock (EST & CST) correctly.
     
  7. macrumors member

    Joined:
    Oct 1, 2011
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

    Battery drainer. I turned it off.
     
  8. macrumors demi-god

    Shrink

    Joined:
    Feb 26, 2011
    Location:
    New England, USA
    #8
    Just curious, how much drain on the battery can displaying the time cause?

    Mine's fine...displaying the correct time.
     
  9. macrumors demi-god

    Gav2k

    Joined:
    Jul 24, 2009
    #9
    Wirelessly posted (iPhone 4s: Mozilla/5.0 (iPhone; CPU iPhone OS 5_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B179 Safari/7534.48.3)

    It's not a battery drainer as the time signal is embedded in the networks signal.

    However the automatically set time zone in the location services does drain the battery as it uses gps to adjust your time some etc.
     
  10. macrumors 65816

    viewfly

    Joined:
    May 1, 2009
    #10
    Let's be clear. There are two time settings.

    Settings/General/Date & Time/Set Automatically

    will not drain any battery. This is really all you need on.

    In Settings/Location Services/System Services/Setting Time Zone

    You really don't need on, unless you are outside of cellular coverage (or some odd carrier that doesn't send time signals to the phone, rare). This will drain battery life as it uses the phones GPS system.
     
  11. thread starter macrumors 6502

    Joined:
    Jan 17, 2012
    #11
    My complaint is that Set Automatically should be correct no matter what. You know when you turn it on, it sets a location for you. Unfortunately for me, the default location it sets (and greyed out so I can't change it), is a location 1 time zone left of me. So it's an hour behind. I know I can just set the time manually, but obviously I'm bothered that it isn't working correctly.
     
  12. macrumors 65816

    viewfly

    Joined:
    May 1, 2009
    #12
    That doesn't matter. But you can change it by turning off, set automatically. It will become ungreyed, and the set it, and turn set time & date back to automatically.

    The time is set by the carrier towers regardless of that setting. Try the above. If that doesn't work call your carrier. Which do you have Att or Verizon? Also is your iPad on wifi or 3G?

    P.S. Mine is set to NY. I turned it off, set it to LA. Time changed to 3 hours earlier. Turned auto back on and it reset to NY, with NY time. That is how it works. I have the GPS set time zone off, btw, in location settings. that is not needed.
     
  13. macrumors 68020

    sviato

    Joined:
    Oct 27, 2010
    Location:
    HR 9038 A
    #13
    My alarm woke me up at the correct time this morning and the lock screen showed the right time, but when I unlocked the phone it was still an hour behind.

    It automatically fixed itself though within an hour.
     
  14. thread starter macrumors 6502

    Joined:
    Jan 17, 2012
    #14
    It doesn't work that way. The grey is where it thinks your phone is; you can't set that. In my case, the place where it thinks I am is wrong.
     
  15. macrumors 6502

    Joined:
    May 15, 2007
    #15
    Had the same problem this morning. I'm in Los Angeles and have it set automatically. For some reason it says I'm in anchorage Alaska, so I turn off set automatically and can choose Los Angeles and the time is correct, but when I turn set auto back on it goes back to anchorage. A reboot of my iPhone 4s solved it. Good thing I had no alarms set this Sunday morning!
     
  16. macrumors member

    Joined:
    Jan 1, 2012
    #16
    Mine was wrong today too. I'm in AZ so it shouldn't have changed at all. I went into Date & Time & it was set to Denver. Turning off Set Automatically switched it to Phoenix, I didn't have to manually change it.
     
  17. macrumors regular

    Sulten

    Joined:
    Oct 24, 2011
    #17

    I'm in Phx also and mine says Cupertino, I did a reset and turned off and set manually to phx and then turned it back on and still thinks I'm in Cupertino. oh well as long as the time is right I'm good.
     
  18. macrumors newbie

    Joined:
    Aug 11, 2009
    Location:
    Phoenix, AZ
    #18
    I'm in Phoenix too!

    In the middle of the night, Saturday to Sunday, I awoke and the three clocks in my bedroom all differed in display.

    I checked the phone and discovered that Cupertino showed as my location.

    Turning off the automatic time option it too returned to Phoenix.

    I stopped at the Apple store on Sunday and showed this anomaly to a Genius. His phone did exactly the same thing (showed Cupertino).

    He said he'd report it to Apple.
     
  19. macrumors 6502

    Joined:
    May 30, 2002
    #19
    My 4S on 5.0.1 did the same thing. I live in Vermont and had automatically adjust time enabled and during the night it switched my timezone to Chicago. Turning off the automatic setting put things right.

    Perhaps it sensed my preference for location?
     

Share This Page