iPhoto help please

Discussion in 'macOS' started by drmkaiser, Jun 21, 2006.

  1. drmkaiser macrumors newbie

    Joined:
    Jun 21, 2006
    #1
    I am a new iPhoto user. I have successfully downloaded pics from my camera, edited them, then tried to export. That failed (I'll deal with that later), but now while I see the thumbnails in the library and the album, I can't see the actual pictures at all. For example, if I try to expand as if to edit, the screen stays blank with a spinning circle of death. What happened? How to resolve? (I could re-download from the camera as I did not erase, and re-edit, but the same thing could happen again).

    many, many thanks.
     
  2. realityisterror macrumors 65816

    realityisterror

    Joined:
    Aug 30, 2003
    Location:
    Snellville, GA
    #2
    It sounds like a corrupt library file or maybe just a few pictures.
    If you just have that one set, and the edits weren't a lot of work, you might consider deleting your iPhoto folder and starting from scratch.
    If something's wrong with your library this early on, it'll only cause hell later.
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    Did you move or rename any files within the iPhoto Library folder? Unless there's a problem with your camera, you could try rebuilding your iPhoto library. :)
     
  4. drmkaiser thread starter macrumors newbie

    Joined:
    Jun 21, 2006
    #4
    Thanks. I'll try deleting and start again. Re-editing will not be a huge deal.

    I did try to re-name in order to export. That might have caused the problem. It's strange, as the files are clearly present.... just not accessable within iPhoto.

    Thanks to both of you for your suggestions.

    mike :)
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Okay, don't edit (move or rename) anything from within the iPhoto Library folder. Do it all from iPhoto and you should be fine. :)
     

Share This Page