iPhoto troubles, will not open

Discussion in 'Mac Applications and Mac App Store' started by Yeti60, Jun 9, 2009.

  1. macrumors member

    Joined:
    May 26, 2009
    #1
    Ok, I'm having this annoying problem with iPhoto.
    When I click to open the application it says that the photo library needs to be upgraded to work with this version of iPhoto. So I have the choice to upgrade. But I can't click it because another screen pops up saying that iPhoto quit unexpectedly. I can ignore it, send a report, or relaunch the application.

    This happens every single time, and I can no longer access my photo library. How do I fix this?
     
  2. macrumors regular

    Joined:
    Mar 27, 2007
    #2
    Perhaps you might purchase a legitimate copy of iLife '09?
     
  3. thread starter macrumors member

    Joined:
    May 26, 2009
    #3
    so I have to buy a new version of what I already have?
     
  4. macrumors regular

    Joined:
    Mar 27, 2007
    #4
    So, are you saying you've got a pirated copy of '09, but previously had a working version of '08 on your drive? If that's the case, too bad, you're stealing software, right? Maybe I'm wrong, but I'll guess this is what's going on.

    But, if you have a legit copy of either iLife '08 or '09, and iPhoto it just won't open, you may be able to repair it:

    1. Delete the com.apple.iPhoto.plist file from the HD/Users/YourName/library/preferences folder. (You'll need to reset your User options afterwards. These include minor settings like the window color, etc. And, if you've moved your library you'll need to point iPhoto at it again.)

    2. Repair Permissions using Disk Utility
     
  5. thread starter macrumors member

    Joined:
    May 26, 2009
    #5
    I'm not sure where you got the idea that I had a pirated copy of iLife... :confused:
    I have iLife '08 including iPhoto. I've had no problems with it until the last couple days or so.

    So you're sure those two steps will fix my problem? Cause I don't want to go messing with things that could potentially mess me up further...
     
  6. macrumors regular

    Joined:
    Mar 27, 2007
    #6
    This is what makeds me think you're trying to run '09 with an original '08 install:

    the photo library needs to be upgraded to work with this version of iPhoto

    The instructions I provide might work, and only take a few minutes to carry out. If they don't, you'll need to reinstall the app.
     
  7. thread starter macrumors member

    Joined:
    May 26, 2009
    #7
    Ok, I've found the thing to delete for step 1.
    But before I do... how will this effect the pictures I have stored on there.

    Also, what would be the next step after I delete it?
     
  8. macrumors 65816

    Joined:
    Aug 18, 2005
    #8
    The plist file is a simple text file that has your preferences for iPhoto. It could be that this is corrupt preventing something. The most it would do would be to reset your preferences for iPhoto (such as colour of the background, and your other preference settings).

    iPhoto opens and checks the plist for your preferences.
    If iPhoto opens and doesn't see it, it will just make a new one with default settings.

    The safe way to do it would be to move it to your desktop or something. If it turns out NOT to be the issue, you can reinstate it.
     
  9. thread starter macrumors member

    Joined:
    May 26, 2009
    #9
    I tried what you recommended and no dice. Nothing changed. Any other ideas?
     
  10. macrumors 6502a

    MacGeek7

    Joined:
    Aug 25, 2007
    #10
    I had this same problem with iPhoto going from 8.0.2 to 8.0.3, my version was not pirated but for some reason it kept crashing after the 8.0.3 update. I had to go back in Time Machine and restore 8.0.2 iPhoto and everything is fine now.

    So if you have Time Machine that's what I'd suggest doing, worked for me - good luck.
     
  11. thread starter macrumors member

    Joined:
    May 26, 2009
    #11
    Arggg I have Time Machine, but I haven't set it up yet. I didn't think I would need it so soon so I procrastinated :mad:
     
  12. macrumors member

    Joined:
    May 19, 2008
    #12
    I just ran software update on both of my macs last night. Both have legit copies of iLife 09 on them. When I opened iphoto on the first Mac, it said it needed to run an upgrade. It took about 2 min and when it was complete, everything was back to normal. On Mac #2, I got the same error when I opened iphoto, only this time it crashes everytime before the "upgrade" is even able to start.

    Somehow the software updates that Apple pushed out made the Iphotos think they were 8.03.
     
  13. thread starter macrumors member

    Joined:
    May 26, 2009
    #13

    Thats exactly what happened to me.

    Sounds like its pretty common. Hopefully they will address it soon.
     
  14. macrumors member

    Joined:
    May 19, 2008
    #14
    So last night I tried to reinstall iLife 09. I put the disk in, but Iphoto is greyed out and says "skip" next to the check box. So it thinks O9 is installed and won't let me redo it.
     
  15. Mal
    macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #15
    Start up iPhoto with Cmd-Opt held down on the keyboard. Check all of the boxes in the dialog box that comes up, and hit Enter. After a few minutes, iPhoto will have repaired the database and hopefully bring an end to your troubles.

    jW
     
  16. macrumors member

    Joined:
    May 19, 2008
    #16
    I have tried that but it crashes and quits before you can do anything. It is impossible to get any boxes checked becuase it is gone in 1 second.
     
  17. thread starter macrumors member

    Joined:
    May 26, 2009
    #17

    Yeah, he's right, it says to upgrade the library, but before you can do anything it just comes up with the error message. Really annoying.
     
  18. macrumors member

    Joined:
    May 19, 2008
    #18
    I have fixed my issue!!! I think it was caused because my wife uses Eye-Fi to import photos from her camera and it tried to start importing some pics before the upgrade was complete.

    This thread did the trick for me:

    http://discussions.apple.com/thread.jspa?threadID=2027766&tstart=0

    Once i moved those photos from "auto import" to my desktop, everything loaded and ran fine. Then, I simply dragged them from the desktop back into the photos once the upgrade had completed.

    I hope this helps!

    Tim
     
  19. macrumors member

    Joined:
    May 19, 2008
    #19
    P.S. I did not do this:

    "Try deleting the iPhoto preference file - "your username" ==> library ==> preferences ==> com.apple.iPhoto.plist -"

    because I didn't want to loose any settings or prefs until i had tried everything.

    Good luck!
     
  20. thread starter macrumors member

    Joined:
    May 26, 2009
    #20
    Yup this worked for me also.
    Finder>[your user name]>Pictures>control click on iPhoto Library and select "show package contents">take the Auto Import folder and move it to the desktop.

    Thats what I did and everything works fine now.
    Thanks
     
  21. macrumors newbie

    Joined:
    Jun 14, 2009
    #21
    yeah.. it worked with me as well. Now my iPhoto works fine. :)
    Thanks everyone!!
     
  22. macrumors newbie

    Joined:
    May 23, 2008
    #22
    iphoto troubles also

    I had the same problem with iphoto saying it needed to be updated and it happened after I burned a disk from my newer macbook with iphoto to transfer photos to my imac. The imac has iphoto '08 and laptop has iphoto '09 and it started after i put the burned disk in to load the photos to the imac.

    So I put the picture folders from the disk to the desktop and removed the burned disk from the drive and reopened iphoto and imported the photo files to iphoto via click and drag and it seems to have solved the problem.

    Lucky I guess?
    :confused:
     

Share This Page