iPod disk can not be read or written to

Discussion in 'iPod' started by eyebeaz, May 28, 2008.

  1. macrumors 6502

    Joined:
    Oct 22, 2006
    #1
    My iPod hasn't given me any trouble for the 5 months that I have owned it and all of a sudden when I plug it in, it starts to sync automatically (as it is set to do) and I get the error message "Attempting to copy to the disk 'Aaron's iPod' failed. The disk could not be read from or written to." Does anyone know what could be wrong here? The iPod still plays music just fine so I am assuming the disk is not damaged. I have not dropped it. Any help or advice would be greatly appreciated! Thanks in advance.
     
  2. macrumors regular

    Joined:
    May 21, 2008
    Location:
    North of The 'Nati
    #2
    Do you have iTunes set to automatically synch the iPod?
     
  3. thread starter macrumors 6502

    Joined:
    Oct 22, 2006
  4. macrumors regular

    Joined:
    May 21, 2008
    Location:
    North of The 'Nati
    #4
    Yup. Just saw where you said you had it on. :eek:

    Hold on a sec. I want to check something.
     
  5. macrumors regular

    Joined:
    May 21, 2008
    Location:
    North of The 'Nati
  6. macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    上海 (Shanghai)
  7. macrumors 65816

    Galley

    Joined:
    Mar 24, 2008
    #7
    The same thing happened to me. Turns out it was my external hard drive that was failing, and not my iPod classic.
     
  8. macrumors newbie

    Joined:
    Sep 28, 2008
    #8
    I know.

    Well. I had the same problem it worked perfectly for me, I was trying to put cracked ipas on my 8gb ipod touch, on firmware 2.1, and i had to replace mobile installation with another one, and i screwed up something so when let itunes automatically sync my music into my ipod touch, it would say Attempting to copy to the disk 'Jackiewab' failed. The disk could not be read from or written to." Any ways, i found this in a another forum, it worked for me, i dont know if it will work for you but it did give me the exact same problem, just set it to "Manually manage music and videos" in the summary(when you plug in yoru ipod to itunes)
    And after that i was able to listen to music and watch videos on my ipod touch. Anyways tell me if it works
    PS:eek:r you could go ask a proffessional"
    Cheers:):apple::apple::apple:
    :apple:Forever
    Jackie.
     
  9. macrumors newbie

    Joined:
    Sep 28, 2008
    #9
    Ps 2

    i have also tried to restore it doesnt work so dont bother trying
     
  10. macrumors newbie

    Joined:
    Mar 10, 2009
    #10
    one or the other

    I had the same issue. Kept getting "the disk could not be read from or written to" message.
    I tried two things at once, so I'm not sure which one worked, but the ipod is syncing again.

    1. Ejected all of my external hard drives.
    2. Ejected my ipod then connected it to a different USB port.

    Synced like a charm.
     
  11. macrumors newbie

    Joined:
    Mar 21, 2010
    #11
    This really worked!

    Shocking, but this really worked. I had the same issue with my iPhone so I unplugged my NAS, plugged it back in, and then used a different USB connection to connect my iPhone to my PC. Voila! it synced just like xamaxam said. I've had consistent problems with my PC not being able to "see" my NAS so I think that was what did it. I doubt it was the USB because iTunes diagnostics work just fine.
     
  12. macrumors regular

    macbrooke

    Joined:
    Jun 21, 2006
    Location:
    Toronto, Ontario!
    #12
    This happened to me in the summer, I thought the iPod was defective it was still under warranty so I took it into Apple, anyhow it synced fine on the store computer :rolleyes: turns out there was something wrong with the PC I was attempting to sync it to (my husbands) I came home and tried it on another computer and it was ok.
     
  13. macrumors newbie

    Joined:
    Sep 6, 2009
    #13
    same problem with a drobo

    agghhh.. I was having the same problem ever since i moved my itunes drive to a drobo. Due to the timing i knew it was something to do with the drobo. As it turns out if i connect my drobo via firewire I cannot sync media to my iphone 3GS (contacts, cal, etc sync fine). Switch the drobo to a USB connection however and all is well!

    Wierd....

    jonnie
     
  14. macrumors newbie

    Joined:
    Sep 6, 2010
    #14
    Thanks, that worked

    I have no idea why that worked, but it did. Thank you so much for posting.
     

Share This Page