1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Is my logic board dead?

Discussion in 'OS X Mountain Lion (10.8)' started by H2SO4, Sep 27, 2012.

  1. H2SO4, Sep 27, 2012
    Last edited: Sep 27, 2012

    macrumors 68000

    I was posting this elsewhere but thought I'd try here.....

    My 1st gen Mac Pro will only start from one particular drive, (Corsair Force 3 120GB SSD), that is about 30% full in Bay one. If in the wrong bay I just get the spinning gear indefinitely, if in the right bay then after pressing the power button;
    @ 8 secs white screen.
    @ 28 secs Apple logo.
    @ 34 secs spinning gear.
    @89 secs can hear the other drives spin down.
    @99 secs I get the login screen.I have two 10.8 clones and two 10.7 clones but they will only work when on the SSD in bay one. So far for the most recent restart I've;

    Removed everything apart from the minimum of components --

    Reinstalled original RAM, (in total I can choose between two pairs of 512MB, and a pair 2GB - matched and bought in pairs). I have run testdisk 6.13 as additional RAM test.

    Tried an alternate graphcs card. I have an Apple branded 5770 and and Apple branded 7300GT.

    Swapped hard drive bays.

    Removed both optical drives.

    Unplugged speaker and headphones.

    Unplugged all USB and firewire devices. (Keyboard/trackpad/display are all Apple ones).

    Unplugged ethernet.

    Running the command, nvram -p in terminal outputs nvram: nvram is not supported on this system.

    DVDPlayer.app quits silently when any .img file is mounted with terminal code: Error getting a reference to /options.

    The Start up Disk Pref Pane, will not allow me to make changes. The message I get is 'The bless tool was unable to set the current boot disk'.

    I can boot from the original optical disc that came with it and use disk utility but cannot install Tiger from it. It never gets as far as choosing the destination.

    The original AHT that came will not run, pressing D during start will eventually boot the Mac from the normal system.

    Any takers out there?

  2. macrumors 68000


    Am now on 10.8.2, (after having made a new USB installer).
    Still have the NVRAM problem though. Can someone with a MacPro and ML help me out with something please for comparative purposes?
    Here is mine, but can you post the contents of your /System/Library/Extensions/AppleSMBIOS.kext/Contents/Info.plist;

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <string>System Management BIOS Driver</string>
    <key>Platform BIOS Match</key>
    <string>Copyright © 2005-2011 Apple Inc. All rights reserved.</string>
  3. macrumors 6502a


    Sounds more like a problem with your 10.8 installation. (thats, if you only have problem on 10.8) otherwise, try wiping the drive completely and reinstall everything from scratch. If that still doesn't work, see if any of the diagnostic lights (on the RAM bay, processor are illuminated in RED).

    EDIT: have you tried to do a SMC reset and or a PRAM reset?
  4. macrumors 68000

    Just done that. My RAM seems cool, I get the right indications back from it anyway, (a quick flash at boot). I'm installing to a brand new SSD formatted using DU to GUID etc etc.....

    I'll try 10.7 again in a mo......

    EDIT: Tried both the SMC and NVRAM, including removing the battery for long enough for the Mac to forget the time. No dice.
  5. hackerwayne, Oct 8, 2012
    Last edited: Oct 8, 2012

    macrumors 6502a


    Put your SSD into bay #2 (i know it won't boot, do it purposely) then verbose boot the Mac (hold down CMD+V while powering it on release when you see a black screen with words, make sure no DVDs are in the DVD drive and no other HDDs in other bays)

    Then, wait until it hangs, take a camera snapshot it and upload it here.

    Quoted from your thread @ Apple Support.

    My startup log gives me the following;
    BOOT_TIME 1349245410 0
    Running kernel space in FIPS MODE
    corecrypto.kext FIPS integrity POST test passed!
    corecrypto.kext FIPS AES CBC POST test passed!
    corecrypto.kext FIPS TDES CBC POST test passed!
    corecrypto.kext FIPS SHA POST test passed!
    corecrypto.kext FIPS HMAC POST test passed!
    corecrypto.kext FIPS ECDSA POST test passed!
    corecrypto.kext FIPS DRBG POST test passed!
    corecrypto.kext FIPS POST passed!

    Above red lines indicated your system is running full secure mode aka FIPS mode. Disable it, this is definitely the root cause of the problem as FIPS WILL disable the ability to swap drive bays and not boot from other partitions.

    AppleACPICPU: ProcessorId=0 LocalApicId=0 Enabled
    AppleACPICPU: ProcessorId=1 LocalApicId=1 Enabled
    AppleACPICPU: ProcessorId=2 LocalApicId=6 Enabled
    AppleACPICPU: ProcessorId=3 LocalApicId=7 Enabled
    AppleACPICPU: ProcessorId=4 LocalApicId=0 Disabled
    AppleACPICPU: ProcessorId=5 LocalApicId=0 Disabled
    AppleACPICPU: ProcessorId=6 LocalApicId=0 Disabled
    AppleACPICPU: ProcessorId=7 LocalApicId=0 Disabled
    calling mpo_policy_init for TMSafetyNet
    Security policy loaded: Safety net for Time Machine (TMSafetyNet)
    calling mpo_policy_init for Sandbox
    Security policy loaded: Seatbelt sandbox policy (Sandbox)
    calling mpo_policy_init for Quarantine
    Security policy loaded: Quarantine policy (Quarantine)
    Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California. All rights reserved.

    MAC Framework successfully initialized
    using 16384 buffer headers and 10240 cluster IO buffer headers
    IOAPIC: Version 0x20 Vectors 64:87
    ACPI: System State [S0 S3 S4 S5]
    PFM64 (36 cpu) 0xf80000000, 0x80000000
    AppleIntelCPUPowerManagement: Enabling legacy HPET check
    AppleIntelCPUPowerManagement: (built 00:59:42 Aug 25 2012) initialization complete
    [ PCI configuration begin ]
    PCI configuration changed (bridge=4 device=1 cardbus=0)
    [ PCI configuration end, bridges 17 devices 26 ]
    FireWire (OHCI) TI ID 8025 built-in now active, GUID 0016cbfffe75220e; max speed s800.
    ERROR: FireWire unable to determine security-mode; defaulting to full-secure. <This is because you enabled FIPS, nothing to worry about
    mbinit: done [64 MB total pool size, (42/21) split]
    Pthread support ABORTS when sync kernel primitives misused
    rooting via boot-uuid from /chosen: THE UUID OF MY SSD GOES HERE
    Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>
    com.apple.AppleFSCompressionTypeZlib kmod start
    com.apple.AppleFSCompressionTypeDataless kmod start
    com.apple.AppleFSCompressionTypeZlib load succeeded
    com.apple.AppleFSCompressionTypeDataless load succeeded
    AppleIntelCPUPowerManagementClient: ready
    wl0: Broadcom BCM4328 802.11 Wireless Controller
    Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/PRT0 @0/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDri ver/Corsair Force 3 SSD Media/IOGUIDPartitionScheme/BOOT VOLUME@2
    BSD root: disk0s2, major 1, minor 15<This means nothing, every Mac has that
    Kernel is LP64< Are you attempting to boot Mountain Lion?
    IPv6 packet filtering initialized, default to accept, logging disabled
    AppleIntel8254XEthernet: Ethernet address 00:17:f2:06:fe:d4
    AppleIntel8254XEthernet: Ethernet address 00:17:f2:06:fe:d5
    AirPort_Brcm43224: Ethernet address 00:19:e3:0a:f2:bc

    For the next time, unplug the Ethernet temporarily
    IO80211Controller::dataLinkLayerAttachComplete(): adding AppleEFINVRAM notification
    macx_swapon SUCCESS
    Waiting for DSMOS...
    DSMOS has arrived
    [CSRBluetoothHCIControllerUSBTransport][start] -- completed
    Previous Shutdown Cause: 0
    [IOBluetoothHCIController][staticBluetoothHCIControllerTransportShowsUp] -- Received Bluetooth Controller register service notification
    [IOBluetoothHCIController][start] -- completed
    AirPort: Link Down on en2. Reason 8 (Disassociated because station leaving).
    en2::IO80211Interface::postMessage bssid changed
    [IOBluetoothHCIController::setConfigState] calling registerService
    L2TP domain init
    L2TP domain init complete
    l2tp_udp_init_threads: changing # of threads from 0 to 3
    Sound assertion in AppleHDAEngine at line 4346
    Sound assertion in AppleHDAEngine at line 4346
    Sound assertion in AppleHDAEngine at line 4346
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4379
    Sound assertion in AppleHDAEngine at line 4346
    Sound assertion in AppleHDAEngine at line 4346
    Ethernet [Intel8254x]: Link up on en0, 1-Gigabit, Full-duplex, Symmetric flow-control, Debug [792d,af08,0de1,0e00,cde1,2836]
    Ethernet [Intel8254x]: Link up on en0, 1-Gigabit, Full-duplex, Symmetric flow-control, Debug [792d,af08,0de1,0e00,cde1,2807]
    Ethernet [Intel8254x]: Link up on en0, 100-Megabit, Full-duplex, Symmetric flow-control, Debug [792d,6f08,0de1,0e00,4de1,4000]
    [ffffff8010a22000][BNBTrackpadDevice::init][75.15] init is complete
    [ffffff8010a22000][BNBTrackpadDevice::handleStart][75.15] returning 1
    [ffffff801362be00][AppleMultitouchHIDEventDriver::start] entered
    [ffffff8013621100][AppleMultitouchDevice::start] entered
  6. H2SO4, Oct 8, 2012
    Last edited: Oct 9, 2012

    macrumors 68000

    Man how did you learn all this stuff?

    Anyhow, glad that you did.

    Right, as the power on chime sounds like the famous Big Ben I'll wait until everybody is up first. I can actually boot different partitions now. Do you want the boot log from something else?

    Yes this is with an ML boot.

    For the last install I disconnected both DVD drives infact the only things plugged in were my 3.5mm jack headphones, ethernet and the monitor and keyboard, (both Apple).

    Funny thing is tho I don't for the life of me remember enabling FIPS, neither does this guy.


    Lastly does dmesg not do the same as a Cmd V boot?

    EDIT: Ah, I see the difference, with dmesg you actually need to have booted to run the command.

    GAD!!! Right, have just reinstalled with nothing, I repeat nothing plugged in except the minimum and airport off too.
    I wonder if it's because I'm using 10.8.2 instead of 10.8.0 as base for my USB booter?
  7. macrumors 6502a


    So you've disabled FIPS? I learned those during the Hackintosh days lol.. CMD+V is good for troubleshooting when the Mac doesn't actually boot to the desktop, my Mac Pro will always boot Verbose instead of the nice shiny Apple logo, i prefer to see those diag messages. (you can add this to com.apple.boot.plist).
  8. H2SO4, Oct 9, 2012
    Last edited: Oct 9, 2012

    macrumors 68000

    Nope, FIPS won't disable. I tried removing the files and got stuck in a boot loop. In ML they are as per the help files;
    This installation will place the following on your OS X Mountain Lion system: Directory: /usr/libexec/
    Upon restart, your system will automatically perform the required
    Power–On–Self–Test (POST).
    If there is any problem identified with the Apple OSX CoreCrypto Module, the system boot process will log the error to system.log, immediately halt and the system will shutdown. Otherwise, the normal boot process will continue without issue.
    If a failure is detected and the system is shutdown, you should perform the following to correct it:
    1) Restart the system in Single-User Mode.
    (Hold down the <command> and <S> keys during restart) Starting up in single-user mode
    2) Review the System Log for clarification of problem(s) detected. Secure Log is located at: /var/log/system.log
    3) If Tool related issues are found, re-run this installer and try again.
    4) If the integrity of the Security Module has failed validation, it is best to re-Install OS X Mountain Lion, any software updates as well as re-installing this tool.
    5) If you are still unable to identify the problem, it is suggested you search the Apple Support Website for any "FIPS" Knowledge Base Articles and proceed as instructed.
    If you need further assistance, contact AppleCare for support.

    A spotlight search of my drive reveals the following -

    Removing corecrypto.kext is what caused the boot loop. IIRC removing the other files above did nothing. I'll try again I think.
  9. H2SO4, Oct 9, 2012
    Last edited by a moderator: Oct 9, 2012

    macrumors 68000

    Tell me, do you have corecrypto.kext on your system at all? Should be in /System/Library/Extensions

    CONFIRMATION. Removing that kext causes a boot loop and prevents booting from anything except an internal drive resulting in the below. (In my testing);
  10. macrumors 6502a


    Yes, i do have CoreCrypto.kext. Have you tried a installing on a brand new HDD or another SSD?

    EDIT/EDIT! Nvm, i tried removing that kext, ends up the same thing lol..

    Attached Files:

  11. macrumors 68000

    Yep, the SSD is new, got it yesterday from OWC, (formatted as GUID MacOS Extended Journaled). As to fault CPU: 0x3, googling now.....
  12. macrumors 6502a


    Ok did some in depth studies about FIPS. Where did you get your installer from? Seems that the FIPS came from the installer itself. Ignore the CPU Fault message, just tried it on my MacBook Air (removing CoreCrypto.kext it gave me the same error message too)
  13. macrumors 68000

    Exactly what do you mean by installer? Are you referring to the original ML download? If so, downloaded from the App Store myself with a MacBook Air.
  14. macrumors 6502a


    Yes im referring to the ML download. Do you have Lion in hand? If yes, burn it in a DVD instead of putting it in a thumb drive (unless you have another T.drive.) and try. Check if the T. drive has FIPS enabled
  15. macrumors 68000

    Will do it now......Have just noticed one difference. The USB is Mac OS extended whilst my other drives are Mac OS extended Journaled. I wonder if that makes a difference?
  16. macrumors 6502a


    Well it doesn't really make a difference Journaled drive generally runs faster but anyway try with a different USB
  17. H2SO4, Oct 9, 2012
    Last edited: Oct 9, 2012

    macrumors 68000

    Well that will take a while. I'll have to go out and buy one, but needs must so I will.
    You are a gentleman, thanks for your input.

    Disk Utility ;
    When no disk is selected -


    But with a disk selected -

  18. macrumors 6502a


    That kinda means the drive already has no encryption
  19. macrumors 68000

    Hi Wayne. I think the following has been mentioned before but as I'm running out of steam with this FIPS thing.......

    Is it possible to install ML on my sisters Air. Edit the support plists as necessary. Clone to my Mac Pro then boot and use Migration assistant to bring the other accounts, (on a separate HD), across?
  20. macrumors 6502a


    You don't have to modify support plist as it will just work out of the box. Ive done that many times.\

    EDIT: Don't use Migration Assistant. Verify that the problem is fixed before doing anything else. If the problem came back after using Migration Assistant, then transfer files one by one
  21. H2SO4, Oct 10, 2012
    Last edited: Oct 10, 2012

    macrumors 68000

    Funny, got the prohibit sign at boot. Had to use the hacked folders to make it work. But I'm going to zero the drive and re-try.

    Right, this how it went -
    1. Completely formatted then zeroed and repartitioned a spare 500GB drive on the MP1,1.
    2. Switched on the Air and upgraded Lion to Mountain Lion.
    3. Ran dmesg which came up with the same Crypto messages as my Mac Pro.
    4. Cloned its drive to an FW800 portable using Carbon Copy Cloner.
    5. Modded the clone with the MLHacks stuff, (using the Air), and keeping the originals safely.
    6. Cloned the Air to a partition on the MP1,1.
    7. Boot the pro and run dmesg.............which I am expecting to come up with the Crypto stuff of course, but at least I know that iMessages now works properly.

    8. NVRAM is functional on the Air but not on the Pro so I've made the assumption that those FIPS messages are not in fact the limiting factor.

    I think my logic abord may be dying after all?

    Gonna go to the Apple Store about the FIPS thing though.
  22. macrumors 6502a


    At this point i suspect the RAM is the culprit
  23. macrumors 68000

    I'll put the original single GIG of RAM I have back in and try to reinstall Tiger I think from the DVD.
  24. macrumors 68000

    Right, done that and Tiger runs. It even allows me to change the boot disc. I reckon my problem is that I used 10.8.2 as a base for my install.
  25. macrumors 6502a


    So can you try to run hardware test?

Share This Page